Testlink 1.7.4 in Ubuntu 9.04 & XAMPP

Ask community to help.

Moderators: Amaradana, TurboPT, TL Developers

Testlink 1.7.4 in Ubuntu 9.04 & XAMPP

Postby nithyakesan » Fri Aug 28, 2009 11:01 pm

Hi,
I was successful in installing Testlink 1.7.4 after installing required packages from XAMPP.

After the installation, when i try to login, i get a flooding of error messages, and not the login screen. Pasted a snapshot fo them below:
Can anyone help me with this?

Thanks,
Nithya.

Strict Standards: Creating default object from empty value in /opt/lampp/htdocs/testlink/cfg/const.inc.php on line 196

Strict Standards: Creating default object from empty value in /opt/lampp/htdocs/testlink/cfg/const.inc.php on line 203

Strict Standards: Creating default object from empty value in /opt/lampp/htdocs/testlink/cfg/const.inc.php on line 300

Deprecated: Function ereg_replace() is deprecated in /opt/lampp/htdocs/testlink/lib/functions/lang_api.php on line 129

Deprecated: Function ereg_replace() is deprecated in /opt/lampp/htdocs/testlink/lib/functions/lang_api.php on line 129

Deprecated: Function ereg_replace() is deprecated in /opt/lampp/htdocs/testlink/lib/functions/lang_api.php on line 129

Deprecated: Function ereg_replace() is deprecated in /opt/lampp/htdocs/testlink/lib/functions/lang_api.php on line 129

Deprecated: Function ereg_replace() is deprecated in /opt/lampp/htdocs/testlink/lib/functions/lang_api.php on line 129
nithyakesan
TestLink user
 
Posts: 1
Joined: Fri Aug 28, 2009 10:55 pm

Re: Testlink 1.7.4 in Ubuntu 9.04 & XAMPP

Postby caditopoa » Thu May 20, 2010 2:42 pm

for problems on line 129 replace this:

[testlink]\lib\functions\lang_api.php

$t_lang_var = ereg_replace( '^TLS_', '', $t_var );
for this:
$t_lang_var = preg_replace( '/^TLS_/', '', $t_var );

or if u have problems on lines 129, 886 or 889: download this file on 4shared http://www.4shared.com/file/-Q8WZLJy/adodbinc.html

OBS: Para problemas com testlink 1.7.4 no windows 7(nao testei em outros win) na linha 886 do arquivo adodb.inc.php
faça o download e substitua o arquivo na pasta. com isso sumira tambem o erro da linha 1885.
Ricardo V.O.
TESTCENTER
caditopoa
TestLink user
 
Posts: 1
Joined: Thu May 20, 2010 2:28 pm

Re: Testlink 1.7.4 in Ubuntu 9.04 & XAMPP

Postby fman » Thu May 20, 2010 3:10 pm

1.74 is a too old version, try to upgrade to 1.8.5 and then to 1.9 when this will be available.
1.9 works fine with PHP 5.3
fman
Member of TestLink Community
 
Posts: 3088
Joined: Tue Nov 15, 2005 7:19 am


Return to Installation and configuration



Who is online

Users browsing this forum: No registered users and 3 guests