[SOLVED] Testlink+Bugzilla : Blank Page coming

Ask community to help.

Moderators: Amaradana, TurboPT, TL Developers

[SOLVED] Testlink+Bugzilla : Blank Page coming

Postby rahulp » Thu Mar 11, 2010 12:43 pm

Hi All

I am trying to integrate Testlink and Bugzilla. I am following the documentation in 'tl-bts-howto'. The testink and bugzilla are running fine when run individually. When I try to add the line
Code: Select all
$g_interface_bugs = 'BUGZILLA'

in the file custom_config_inc.php, and try to access Testlink, it gives me a blank page.

I am not sure where I have gone wrong.
Please help me with this.

Regards,.
Rahul
rahulp
TestLink user
 
Posts: 5
Joined: Tue Dec 22, 2009 12:25 pm

Re: Testlink+Bugzilla : Blank Page coming

Postby padma » Mon Oct 11, 2010 8:49 am

Hi,

I am facing the same problem (Testlink 1.8.4 and Bugzilla 3.6.2).
please help on this.
padma
TestLink user
 
Posts: 6
Joined: Thu Oct 07, 2010 5:46 pm

Re: Testlink+Bugzilla : Blank Page coming

Postby fman » Mon Oct 11, 2010 10:38 am

impossible to help with level of detail
fman
Member of TestLink Community
 
Posts: 3063
Joined: Tue Nov 15, 2005 7:19 am

Re: Testlink+Bugzilla : Blank Page coming

Postby padma » Tue Oct 12, 2010 9:48 am

Hi fman,

Thanks for the reply!
I just followed the instructions in the Testlink manual and have not made any other changes.
when I pasted '$g_interface_bugs = 'BUGZILLA'' in custom_config.inc.php file, page was not rendered.
Could you pls let me know the other configurations to be taken care of, if any?
What specific details u need to solve this?
(I am trying this on CentOS)

Thanks,
Padma.
padma
TestLink user
 
Posts: 6
Joined: Thu Oct 07, 2010 5:46 pm

Re: Testlink+Bugzilla : Blank Page coming

Postby fman » Tue Oct 12, 2010 10:37 am

start looking to TL event viewer, and apache logs
have you followed all info present on docs distributed with TL ?
have you looked for similar post on forum ?
try getting from sourceforge our distrubution bundle with bugzilla for windows and use it as playground
fman
Member of TestLink Community
 
Posts: 3063
Joined: Tue Nov 15, 2005 7:19 am

Re: Testlink+Bugzilla : Blank Page coming

Postby padma » Wed Oct 13, 2010 5:18 am

Thanks!
I was able to find the problem using Apache logs :)
padma
TestLink user
 
Posts: 6
Joined: Thu Oct 07, 2010 5:46 pm

Re: Testlink+Bugzilla : Blank Page coming

Postby fman » Wed Oct 13, 2010 7:55 am

Please ALWAYS when you are able to solve a problem, post also solution in order to help others, that may be in future can have same problem.
fman
Member of TestLink Community
 
Posts: 3063
Joined: Tue Nov 15, 2005 7:19 am

Re: Testlink+Bugzilla : Blank Page coming

Postby padma » Thu Oct 14, 2010 7:52 am

Hi,
I Added these lines to the testlink/custom_config.inc.php file:

$g_interface_bugs='BUGZILLA';
//At 1st, I missed out these 2 lines
$g_bugInterfaceOn = false;
$g_bugInterface = null;

And in testlink/cfg/bugzilla.cfg.php (All these entries are must):

define('BUG_TRACK_DB_HOST', '<site>');
define('BUG_TRACK_DB_NAME', 'bugs');
define('BUG_TRACK_DB_USER', '<user>');
define('BUG_TRACK_DB_PASS', '<Password>');
define('BUG_TRACK_HREF', 'http://<site>/bugzilla/show_bug.cgi?id=');
define('BUG_TRACK_ENTER_BUG_HREF', 'http://<site>/bugzilla/');
define('BUG_TRACK_DB_CHARSET', 'utf8');
define('BUG_TRACK_DB_TYPE','mysql');

Its working fine now :)
padma
TestLink user
 
Posts: 6
Joined: Thu Oct 07, 2010 5:46 pm


Return to Installation and configuration



Who is online

Users browsing this forum: No registered users and 2 guests