BTS connection problem with 19.4 beta 4 XAMPP (SOLVED)

Ask community to help.

Moderators: Amaradana, TurboPT, TL Developers

BTS connection problem with 19.4 beta 4 XAMPP (SOLVED)

Postby julien_hervouet » Thu May 06, 2010 11:57 am

Hello,

First of all thanks for the XAMPP bundle it's very usefull.

Here is the description of the problem :
- I am under windows XP
- I use the 1.9 beta 4 version

When I configure BUGZILLA or MANTIS in the custom config file and when I went in the execute part and if I clic on a Test Case I have the following error :

Fatal error: require_once() [function.require]: Failed opening required 'ADODB_[configure_bug_track_db_type].class.php' (include_path='.;C:\test\xampp\php\PEAR;.;C:\test\xampp\htdocs\testlink-1.9.beta4\lib\functions\') in C:\test\xampp\htdocs\testlink-1.9.beta4\lib\functions\common.php on line 93

When I let the default value to NO ($g_interface_bugs = 'NO';) I have not got any problem.
I can access correctly to the BTS instance through the dedicated URL.

Have I missed something?

Thanks in advance

Julien
julien_hervouet
TestLink user
 
Posts: 4
Joined: Thu Apr 15, 2010 2:39 pm

Re: BTS connection problem with 19.4 beta 4 XAMPP

Postby fman » Thu May 06, 2010 7:49 pm

problem seems to be that YOUR CONFIGURATION for BTS integration is incomplete:

I'm sorry I've not added pre-configued examples.

Here a working one for BUGZILLA - you have to configure on bugzilla.cfg.php :

define('BUG_TRACK_DB_HOST', 'localhost:8306');
define('BUG_TRACK_DB_NAME', 'bugs');
define('BUG_TRACK_DB_CHARSET', 'UTF-8');
define('BUG_TRACK_DB_TYPE','mysql');
define('BUG_TRACK_DB_USER', 'root');
define('BUG_TRACK_DB_PASS', 'root');
define('BUG_TRACK_HREF', "http://localhost:8600/bugzilla-3.6/show_bug.cgi?id=");
define('BUG_TRACK_ENTER_BUG_HREF',"http://http://localhost:8600/bugzilla-3.6/");

think now you can try to config for MANTIS
fman
Member of TestLink Community
 
Posts: 3088
Joined: Tue Nov 15, 2005 7:19 am

Re: BTS connection problem with 19.4 beta 4 XAMPP

Postby julien_hervouet » Fri May 07, 2010 7:54 am

Hello,

Thanks a lot for your quick answer, it's working well now!

Julien
julien_hervouet
TestLink user
 
Posts: 4
Joined: Thu Apr 15, 2010 2:39 pm

Re: BTS connection problem with 19.4 beta 4 XAMPP

Postby julien_hervouet » Fri May 07, 2010 8:18 am

For information here is the extract of my mantis.cfg.php file :

define('BUG_TRACK_DB_HOST', 'localhost:8306');
define('BUG_TRACK_DB_NAME', 'bugtracker121');
define('BUG_TRACK_DB_TYPE', 'mysql');
define('BUG_TRACK_DB_USER', 'root');
define('BUG_TRACK_DB_PASS', 'root');
define('BUG_TRACK_HREF', "http://localhost:8600/mantisbt-1.2.1/view.php?id=");
define('BUG_TRACK_ENTER_BUG_HREF',"http://localhost:8600/mantisbt-1.2.1/");

Julien
julien_hervouet
TestLink user
 
Posts: 4
Joined: Thu Apr 15, 2010 2:39 pm

Re: BTS connection problem with 19.4 beta 4 XAMPP (SOLVED)

Postby MarceUru » Thu Aug 12, 2010 8:29 pm

I had the same problem, but with this solution, the application is working fine again.
Thanks a lot.
"Nada se crea, nada se destruye, todo se transforma"
Lavoisier
MarceUru
Advanced user
 
Posts: 23
Joined: Wed Jul 14, 2010 5:49 pm
Location: Montevideo


Return to Installation and configuration



Who is online

Users browsing this forum: No registered users and 3 guests