TL 1.8.4 and JIRA 4.1 integration Missing Button (SOLVED)

Ask community to help.

Moderators: Amaradana, TurboPT, TL Developers

TL 1.8.4 and JIRA 4.1 integration Missing Button (SOLVED)

Postby dlight » Wed Jul 14, 2010 9:08 pm

I have not been able to get TestLink 1.8.4 and JIRA 4.1 working together.

* JIRA is using a mySQL database and is on a remote machine. I am able to remote log-in to the JIRA database via command line from the machine that TestLink is installed on.
* I do not get any errors in the app or the logs.

The problem is that I do not get the column or button that enables me to add bugs after executing a test case. How do I get this button to show?

Here is my configuration:
config.inc.php
Code: Select all
$g_interface_bugs = 'JIRA';


custom_config.inc.php
Code: Select all
<?php
$g_tl_admin_email = 'testers@enquisite.com';
$g_from_email = 'testers@enquisite.com';
$g_return_path_email = 'testers@teamst.org';
$g_smtp_host = 'zimbrainternal.enquisite.com';
$g_interface_bugs = 'JIRASOAP';
?>


cfg/jira.cfg.php
Code: Select all
//Set the bug tracking system Interface to JIRA 3.1.1
/** The DB host to use when connecting to the JIRA db */
define('BUG_TRACK_DB_HOST', 'jira.domain.com');

/** The name of the database that contains the jira tables */
define('BUG_TRACK_DB_NAME', 'jira_4_1');

/** The DB type being used by jira */
define('BUG_TRACK_DB_USER', 'username');

/** The DB password to use for connecting to the jira db */
define('BUG_TRACK_DB_PASS', 'password');

/** link of the web server for jira */
// define('BUG_TRACK_HREF', "http://localhost:8080/secure/Dashboard.jspa");
define('BUG_TRACK_HREF', "http://jira.domain.com:8080/secure/Dashboard.jspa");

/** The DB type to use for connecting to the bugtracking db */
define('BUG_TRACK_DB_TYPE', 'mysql');

/** link to the bugtracking system, for entering new bugs */
define('BUG_TRACK_ENTER_BUG_HREF',"http://jira.domain.com:8080/secure/CreateIssue.jspa");
?>


Any help would be appreciated
dlight
TestLink user
 
Posts: 2
Joined: Wed Jul 14, 2010 8:57 pm

Re: TestLink 1.8.4 and JIRA 4.1 integration Missing Button

Postby dlight » Thu Jul 15, 2010 5:44 pm

I resolved this. I change JIRASOAP to JIRA in custom_config.inc.php
dlight
TestLink user
 
Posts: 2
Joined: Wed Jul 14, 2010 8:57 pm


Return to Installation and configuration



Who is online

Users browsing this forum: Google [Bot] and 2 guests