Difficulties in integrating TestLink with Jira (on Oracle)

Ask community to help.

Moderators: Amaradana, TurboPT, TL Developers

Difficulties in integrating TestLink with Jira (on Oracle)

Postby amaximenkov » Tue Sep 14, 2010 11:43 am

Hi, folks! I desperately need help!!!

I am fighting, trying to put TestLink (1.8.5), working with BTS Jira (4.1.1, Oracle backend).
Gradually I got through many of the issues, been reported in this forum.
The latest situation is as following:
- I got oci8 module installed properly (seen in phpinfo());
- testscript shows successful connection to the jira oracle database;
- I got "bug" icon on the executed test screen.

However, when I press this "bug' icon, I get
Code: Select all
Fatal error: Call to a member function getEnterBugURL() on a non-object in /var/www/tstlnk/lib/execute/bugAdd.php on line 42

And that's it.
Please, help me to get further and to overcome at least this issue right now.
Thanks!
amaximenkov
TestLink user
 
Posts: 6
Joined: Thu Sep 09, 2010 9:27 am

Re: Difficulties in integrating TestLink with Jira (on Oracl

Postby TurboPT » Wed Sep 15, 2010 1:37 am

Looks like you have made the connection. 8)

For the error, does this variable have the right setting in the config.inc.php file?
Code: Select all
$g_interface_bugs
TurboPT
Member of TestLink Community
 
Posts: 339
Joined: Sun Dec 10, 2006 4:51 am

Re: Difficulties in integrating TestLink with Jira (on Oracl

Postby amaximenkov » Wed Sep 15, 2010 6:59 am

To TurboP:
Look, in the config.inc.php I got 'NO", but 'JIRA' in the custom_config.inc.php, while the latter overrides config.inc.php
To be sure I changed to 'JIRA' in config.inc.php as well...
... The error remains the same.
Anyway thanks for the idea, since I'am a bit desperate in fighting this.
amaximenkov
TestLink user
 
Posts: 6
Joined: Thu Sep 09, 2010 9:27 am

Re: Difficulties in integrating TestLink with Jira (on Oracl

Postby TurboPT » Wed Sep 15, 2010 4:24 pm

Is your JIRA insallation using SOAP?

If so, seach the forums for SOAP, there are only about 4 hits -- all in the same post, I believe.

But if not, post again.

Oh, also, in the file that you posted above, there is a $g_bugInterface [object] variable. This must not be getting set somewhere along the way, because that is causing the message at line 42.
TurboPT
Member of TestLink Community
 
Posts: 339
Joined: Sun Dec 10, 2006 4:51 am

Re: Difficulties in integrating TestLink with Jira (on Oracl

Postby amaximenkov » Thu Sep 16, 2010 8:26 am

To: TurboTP
No, it is not using SOAP.
Yes, I have to trace this $g_bugInterface, thought somebody had got the right experience with the same error
amaximenkov
TestLink user
 
Posts: 6
Joined: Thu Sep 09, 2010 9:27 am

Re: Difficulties in integrating TestLink with Jira (on Oracl

Postby TurboPT » Fri Sep 17, 2010 12:50 pm

amaximenkov wrote:Yes, I have to trace this $g_bugInterface, thought somebody had got the right experience with the same error

Let us know if you find anything interesting with that trace, for I'm sure it can be helpful to others.

Also, it might be worth looking at the Events, the server's error log, and the Testlink log directory to see if there might be any other helpful 'clues' that might exist in those areas.
TurboPT
Member of TestLink Community
 
Posts: 339
Joined: Sun Dec 10, 2006 4:51 am


Return to Installation and configuration



Who is online

Users browsing this forum: No registered users and 2 guests