TestLink 1.8/MySQL - performance question

Ask community to help.

Moderators: Amaradana, TurboPT, TL Developers

TestLink 1.8/MySQL - performance question

Postby vwbwood » Wed Nov 10, 2010 7:44 pm

Hey folks -

I did some searching and could not find anything related to my question - which is...

Is there anyone who has experience on keys and indexing with the testlink database. I am seeing some slowness (user experience) and when I view the phpmyadmin "Status" page, I see some red numbers with ref's to improving on the indexes.

Specific areas include:
Handler_read_rnd - 70 M
Handler_read_rnd_next - 4,011.30 M
Select_full_join - 3,499

Anything else I should look for in phpmyadmin?

We are a small installation - maybe 5-7 users at any given moment, approx 4k testcases with several "suites/categories", and no multi-level suites/categories, pretty much the same organisation as with TL1.6 days.

We do use the devkey and API. I don't see issues there (with the API), but I do see issues when running a reports, or the time it takes to render the menu trees (thus the ref to user experience).

Anyone ever try to "tune" up there MySQL, or make index changes for TestLink?

Let me know if there is anything as I missed -
Thanks in advance -
BillW
vwbwood
TestLink user
 
Posts: 5
Joined: Tue Nov 03, 2009 11:00 pm

Re: TestLink 1.8/MySQL - performance question

Postby Amaradana » Thu Nov 11, 2010 7:45 am

I remember few people worked earlier on performace issues.

I suggest you look at the tracker one of the issue that i found is below

http://mantis.testlink.org/view.php?id=1824

and my question why do we do index on PHPMYADMIN, i am not sure if that really help. I think we need to work on our TestLink system to find the performance and for any memory leaks.
Thanks,
TesterWorld
Http://amartester.blogspot.com
Amaradana
Member of TestLink Community
 
Posts: 398
Joined: Mon Feb 16, 2009 11:19 am

Re: TestLink 1.8/MySQL - performance question

Postby vwbwood » Thu Nov 11, 2010 8:46 pm

Thanks for pointing me to the Mantis issue.

It seems that all the comments at the top of that issue point out a "fix" for 1.7 code base. Since that is now closed, and I am referring to 1.8.4, it seems not to apply here.

Later comments on the performance issue seems to point out a continued issue with 1.8. And there is no conclusion according to the Mantis issue.

Any suggestions appreciated...I'll keep poking around. If I find anything interesting, I'll report it.

BillW
vwbwood
TestLink user
 
Posts: 5
Joined: Tue Nov 03, 2009 11:00 pm

Re: TestLink 1.8/MySQL - performance question

Postby Amaradana » Fri Nov 12, 2010 5:31 am

Well, the issue is 1.7 release. Thought it moght help you how to appoach if you go to the issue, and you can contribute in similar apprach for 1.8 release.

If you find any performance degradation in tree loading/ reports / results / execution, You can always can contribute in tuning and after you made your changes in your local box please open a issue in the tracker and contribute the code.
Thanks,
TesterWorld
Http://amartester.blogspot.com
Amaradana
Member of TestLink Community
 
Posts: 398
Joined: Mon Feb 16, 2009 11:19 am

Re: TestLink 1.8/MySQL - performance question

Postby vwbwood » Fri Nov 12, 2010 3:06 pm

If I find anything of value, I would certainly share it -
We continue to use the tool as it is quite useful for us and we make extensive use of the API, specifically test result reporting - the boss loves that!

Take care -
vwbwood
TestLink user
 
Posts: 5
Joined: Tue Nov 03, 2009 11:00 pm


Return to Installation and configuration



Who is online

Users browsing this forum: Google [Bot] and 4 guests

cron