Test Link and Bugzilla - Configuration

Ask community to help.

Moderators: Amaradana, TurboPT, TL Developers

Test Link and Bugzilla - Configuration

Postby Kathirvel » Fri Feb 04, 2011 7:26 am

Hi All,

I have completed the Test Link 1.9 installation and am in the process of completing the configuration.I need to integrate Bugzilla with Test Link.I have gone through the installation manual but got confused with some of the steps.I have configured the below parameters in bugzilla.cfg.php file :

define('BUG_TRACK_DB_HOST', 'localhost');
define('BUG_TRACK_DB_NAME', 'bugs');
define('BUG_TRACK_DB_CHARSET', 'UTF-8');
define('BUG_TRACK_DB_TYPE','mysql');
define('BUG_TRACK_DB_USER', 'root');
define('BUG_TRACK_DB_PASS', 'password');

I thought the above changes would be enough to integrate Bugzilla with Test Link.But then I got confused by reading the manul which talks about TRAC configuration.I have no idea if we really need this to integrate Bugzilla with Test Link.Please let me know TRAC configuration and the complete steps to integrate Bugzilla with Test Link.Thanks in advance.

Regards,

Kathir
Kathirvel
TestLink user
 
Posts: 9
Joined: Fri Jan 28, 2011 10:25 am

Re: Test Link and Bugzilla - Configuration

Postby fman » Fri Feb 04, 2011 8:41 am

1. read carefully ALL DOC AVAILABLE provided with TL
2. do serach on forums

before posting
fman
Member of TestLink Community
 
Posts: 3059
Joined: Tue Nov 15, 2005 7:19 am

Re: Test Link and Bugzilla - Configuration

Postby Kathirvel » Fri Feb 04, 2011 10:25 am

Thanks for your valuable and quick response.I have already gone through the installation manuals and then raised the above doubt.
Kathirvel
TestLink user
 
Posts: 9
Joined: Fri Jan 28, 2011 10:25 am

Re: Test Link and Bugzilla - Configuration

Postby fman » Fri Feb 04, 2011 11:40 am

on TL distrubution there is a PDF with details for MANTIS AND BUGZILLA detailed explanation.
fman
Member of TestLink Community
 
Posts: 3059
Joined: Tue Nov 15, 2005 7:19 am

Re: Test Link and Bugzilla - Configuration

Postby Kathirvel » Tue Feb 08, 2011 11:04 am

Thanks.I have done the below changes:

In bugzilla.cfg.php file:

define('BUG_TRACK_DB_HOST', 'localhost');
define('BUG_TRACK_DB_NAME', 'bugs');
define('BUG_TRACK_DB_CHARSET', 'UTF-8');
define('BUG_TRACK_DB_TYPE','mysql');
define('BUG_TRACK_DB_USER', 'root'); //MySQL user name
define('BUG_TRACK_DB_PASS', 'password');//MySQL password
define('BUG_TRACK_HREF', "http://10.226.142.134:90/show_bug.cgi?id="); //** link of the web server */
define('BUG_TRACK_ENTER_BUG_HREF',"http://10.226.142.134:90/enter_bug.cgi");//** link to the bugtracking system, for entering new bugs */

In custom_config.inc.php file:

Added the below line:

$g_interface_bugs = 'BUGZILLA';

I have followed all the steps mentioned in the document downloaded from the TL distrubution.But still I am not getting the 'Bug Management' icon in the failed test cases.

Request you to please verify if the above changes I have done in those 2 files are correct.Please help.

Regards,

Kathir
Kathirvel
TestLink user
 
Posts: 9
Joined: Fri Jan 28, 2011 10:25 am

Re: Test Link and Bugzilla - Configuration

Postby fman » Tue Feb 08, 2011 8:57 pm

bug management icon has to be present no matter test case exec status, you will find it on the execution table after executing test case
fman
Member of TestLink Community
 
Posts: 3059
Joined: Tue Nov 15, 2005 7:19 am

Re: Test Link and Bugzilla - Configuration

Postby Kathirvel » Thu Feb 10, 2011 7:04 am

Thanks.I have made the following changes to integrate Test Link 1.9 with Bugzilla.Please verify if these changes are correct.The reason why I need your help is that even after these changes , I am not seeing the Bug Management icon in Test Link 1.9.

In bugzilla.cfg.php file:

define('BUG_TRACK_DB_HOST', 'localhost');
define('BUG_TRACK_DB_NAME', 'bugs');
define('BUG_TRACK_DB_CHARSET', 'UTF-8');
define('BUG_TRACK_DB_TYPE','mysql');
define('BUG_TRACK_DB_USER', 'bugs'); //'bugs' DB user name
define('BUG_TRACK_DB_PASS', 'password');//'bugs' DB password
define('BUG_TRACK_HREF', "http://10.226.142.134:90/show_bug.cgi?id="); //** link of the web server */
define('BUG_TRACK_ENTER_BUG_HREF',"http://10.226.142.134:90/enter_bug.cgi");//** link to the bugtracking system, for entering new bugs */

In custom_config.inc.php file:

Added the below line:

$g_interface_bugs = 'BUGZILLA';

Regards,

Kathir
Kathirvel
TestLink user
 
Posts: 9
Joined: Fri Jan 28, 2011 10:25 am

Re: Test Link and Bugzilla - Configuration

Postby Unhandled » Sun Feb 13, 2011 4:41 pm

You shouldn't need to worry about TRAC.

In what directory is your "bugzilla.cfg.php" file located?

Are your bugzilla and testlink databases on the same server? For BUG_TRACK_DB_HOST, try the IP address instead of 'localhost'.

Also, for BUG_TRACK_DB_CHARSET, I use a value of "utf8" instead of "UTF-8", although that probably makes little difference.

Other than above, your settings look fine to me.
Unhandled
Advanced user
 
Posts: 67
Joined: Sun Jan 23, 2011 11:28 pm

Re: Test Link and Bugzilla - Configuration

Postby Kathirvel » Mon Feb 14, 2011 5:30 am

Hi,

Thanks for your reply.

"bugzilla.cfg.php" file is located under this path:C:\wamp\www\testlink\cfg

Yes , my bugzilla and testlink databases are on the same server.For Bugzilla , I am using MySQL 5.0 and for Test Link , I am using the wamp server which has got MySQL 5.5.8 in it.Both are installed on the same server machine.

Here is the code changes as per your instructions:

define('BUG_TRACK_DB_HOST', '10.226.142.134');
define('BUG_TRACK_DB_NAME', 'bugs');
define('BUG_TRACK_DB_CHARSET', 'utf8');
define('BUG_TRACK_DB_TYPE','mysql');
define('BUG_TRACK_DB_USER', 'bugs');//'bugs' DB user name
define('BUG_TRACK_DB_PASS', 'password');//'bugs' DB password
define('BUG_TRACK_HREF', "http://10.226.142.134:90/show_bug.cgi?id=");
define('BUG_TRACK_ENTER_BUG_HREF',"http://10.226.142.134:90/enter_bug.cgi?product=JATO Speedwing BTD");

Even after the above changes are done , I couldnt see the Bugs Management Icon in the test execution page.Please help.
Kathirvel
TestLink user
 
Posts: 9
Joined: Fri Jan 28, 2011 10:25 am

Re: Test Link and Bugzilla - Configuration

Postby fman » Mon Feb 14, 2011 9:35 pm

Try with:
http://sourceforge.net/projects/testlin ... z/download

there you will find a complete system
fman
Member of TestLink Community
 
Posts: 3059
Joined: Tue Nov 15, 2005 7:19 am

Re: Test Link and Bugzilla - Configuration

Postby Kathirvel » Sat May 14, 2011 9:28 am

Kathirvel wrote:Hi,

Thanks for your reply.

"bugzilla.cfg.php" file is located under this path:C:\wamp\www\testlink\cfg

Yes , my bugzilla and testlink databases are on the same server.For Bugzilla , I am using MySQL 5.0 and for Test Link , I am using the wamp server which has got MySQL 5.5.8 in it.Both are installed on the same server machine.

Here is the code changes as per your instructions:

define('BUG_TRACK_DB_HOST', '10.226.142.134');
define('BUG_TRACK_DB_NAME', 'bugs');
define('BUG_TRACK_DB_CHARSET', 'utf8');
define('BUG_TRACK_DB_TYPE','mysql');
define('BUG_TRACK_DB_USER', 'bugs');//'bugs' DB user name
define('BUG_TRACK_DB_PASS', 'password');//'bugs' DB password
define('BUG_TRACK_HREF', "http://10.226.142.134:90/show_bug.cgi?id=");
define('BUG_TRACK_ENTER_BUG_HREF',"http://10.226.142.134:90/enter_bug.cgi?);

Even after the above changes are done , I couldnt see the Bugs Management Icon in the test execution page.Please help.
Kathirvel
TestLink user
 
Posts: 9
Joined: Fri Jan 28, 2011 10:25 am

Re: Test Link and Bugzilla - Configuration

Postby fman » Sat May 14, 2011 10:46 am

Stop posting in any section of forum asking for help or I will remove your user.
fman
Member of TestLink Community
 
Posts: 3059
Joined: Tue Nov 15, 2005 7:19 am

Re: Test Link and Bugzilla - Configuration

Postby milindw » Wed Jun 22, 2011 11:33 am

Hi,
I have got error when i have entered
$g_interface_bugs = 'BUGZILLA';
custom_config.inc.php file.
Please help me
milindw
TestLink user
 
Posts: 2
Joined: Wed Jun 22, 2011 11:14 am

Re: Test Link and Bugzilla - Configuration

Postby TurboPT » Fri Jun 24, 2011 2:48 am

milindw wrote:Hi,
I have got error when i have entered
$g_interface_bugs = 'BUGZILLA';
custom_config.inc.php file.
Please help me

Uhhh, what error, milindw? You have not provided enough information for us to help you.
TurboPT
Member of TestLink Community
 
Posts: 337
Joined: Sun Dec 10, 2006 4:51 am

Re: Test Link and Bugzilla - Configuration

Postby benjamin444 » Fri Aug 05, 2011 8:51 am

I'm using bugzilla and TestLink. I think that TestLink could be better, but is easy to use, fast .... the server is my own PC (ubuntu 6, Apache, MySQL) and it runs very fast.
When I found a bug in a test case, I insert it in bugzilla and add a link in TestLink.
benjamin444
TestLink user
 
Posts: 1
Joined: Fri Aug 05, 2011 8:43 am

Next

Return to Installation and configuration



Who is online

Users browsing this forum: No registered users and 1 guest