TL integration with JIRA, when JIRA uses MSSQL

Ask community to help.

Moderators: Amaradana, TurboPT, TL Developers

TL integration with JIRA, when JIRA uses MSSQL

Postby olgas » Thu Jul 05, 2007 7:39 am

Hi,
I want to integrate testlink 1.7.0 RC 3 with JIRA 3.9.2, which is using MS SQL Server. I have configured config.inc.php and jira.cfg.php, but just after setting define('BUG_TRACK_DB_TYPE', 'mssql'); TL stops loading. If set ‘mysql’ back, TL is loading, but JIRA integration certainly is not working.
Can anybody help?

Thanks,
Olga.
olgas
TestLink user
 
Posts: 2
Joined: Thu Jul 05, 2007 7:28 am

Postby fman » Thu Jul 05, 2007 9:16 am

Best thing to do:
write small page in PHP to check your MSSQL connectivity from PHP..
Or add some echos in the TL code


Stupid questions:
are you sure you have the PHPP MSSQL extension enabled ?
fman
Member of TestLink Community
 
Posts: 3063
Joined: Tue Nov 15, 2005 7:19 am

Postby olgas » Thu Jul 05, 2007 10:12 am

The stupid questions was worthwhile :) I have really forgot about mssql extension. Now TL connected successfully. Thank you!
olgas
TestLink user
 
Posts: 2
Joined: Thu Jul 05, 2007 7:28 am

Postby ashishsa » Wed Mar 26, 2008 8:11 am

I'm facing same issue with JIRA (uses mssql database) integration. And I'm having trouble installing PHP-MSSQL library. Could you please post elaborate instructions how to go about it?
ashishsa
TestLink user
 
Posts: 1
Joined: Wed Mar 26, 2008 8:08 am

Postby davila » Fri Aug 01, 2008 4:05 pm

We've recently migrated to Jira (mssql) for our bug tracking (TL using mysql). We were getting "Connection to your Bug Tracking System has failed:Please check your configuration." but got it figured out (needed mssql extension enabled as mentioned above). There is no longer an error message at login; however, there isn't anything showing up when executing tests for bugs. We might be missing something else in the jira.cfg.php file.

Here is our setup:

* TL 1.7.1 on serverA (GNU/Linux) using MySQL 5.0.27
* Jira Enterprise Edition 3.12.1 on serverB (WindowsXP) using SQL Server 2005 (9.0.1399)

Used PHP 5.1.6 to test the connection from srvrA to srvrB and the connection is successful with:

<?php
mssql_connect("$host", "$usr", "$pass") or die("unable to connect");
echo "Connected to MSSQL<br />";
?>

What could be a cause for the missing bug info when executing tests?
We tried reversing the following, but that didn't help:

/** link of the web server for jira */
define('BUG_TRACK_HREF', "http://<$host>:8080/secure/Dashboard.jspa");

/** link to the bugtracking system, for entering new bugs */
define('BUG_TRACK_ENTER_BUG_HREF',"http://<$host>:8080/browse/");
davila
Advanced user
 
Posts: 28
Joined: Tue May 16, 2006 3:11 pm

Postby davila » Mon Aug 04, 2008 3:38 pm

Well, I revisited my "search" string and found that the 1.7 method is different. All is well and working wonderfully!!

Again, great job TL Team!!
davila
Advanced user
 
Posts: 28
Joined: Tue May 16, 2006 3:11 pm

Postby norti » Thu Aug 14, 2008 2:37 pm

davila wrote:Well, I revisited my "search" string and found that the 1.7 method is different. All is well and working wonderfully!!

Again, great job TL Team!!


And what was the solution? I have the same warning "Connection to your Bug Tracking System has failed:Please check your configuration." using Postgres8 DB.
norti
TestLink user
 
Posts: 6
Joined: Thu Aug 14, 2008 2:23 pm

Postby davila » Thu Aug 14, 2008 2:51 pm

Search the forum for "postgres" there are a few suggestions out there. Also, use PHP to test your connection as shown above.
davila
Advanced user
 
Posts: 28
Joined: Tue May 16, 2006 3:11 pm

Postby norti » Thu Aug 14, 2008 3:20 pm

davila wrote:Search the forum for "postgres" there are a few suggestions out there. Also, use PHP to test your connection as shown above.


Yes, I've read all of those posts, but nothing works.
norti
TestLink user
 
Posts: 6
Joined: Thu Aug 14, 2008 2:23 pm

Postby davila » Thu Aug 14, 2008 4:24 pm

Perhaps create a new post with your setup and a bit more info of the problem. The topic here is not correct for your request.
davila
Advanced user
 
Posts: 28
Joined: Tue May 16, 2006 3:11 pm

Re: TL integration with JIRA, when JIRA uses MSSQL

Postby oileanach » Wed Sep 22, 2010 12:47 pm

Stupid quesion about the stupid question above....

are you sure you have the PHPP MSSQL extension enabled? Where do i enable this?
oileanach
Advanced user
 
Posts: 17
Joined: Wed Sep 08, 2010 3:03 pm


Return to Installation and configuration



Who is online

Users browsing this forum: Google [Bot] and 4 guests