Problem upgrading from 1.9.3 to 1.9.5

Ask community to help.

Moderators: Amaradana, TurboPT, TL Developers

Problem upgrading from 1.9.3 to 1.9.5

Postby davidkeaveny » Fri Dec 21, 2012 1:49 am

I've been running v1.9.3 successfully for the past few months; this morning, I tried upgrading to v1.9.5 so that I could get the new issue tracker integration. The database upgrade went OK, however when I tried running the new application, I was given just a blank page.

Checking the log files, I found the following:

include(): Failed opening 'D:\Testlink\v1.9.5\gui\templates_c\\%%6A^6A5^6A537DD8%%login.tpl.php' for inclusion (include_path='.;C:\php\pear;.;D:\Testlink\v1.9.5\lib\functions\;D:\Testlink\v1.9.5\lib\issuetrackerintegration\;D:\Testlink\v1.9.5\third_party\') - in D:\Testlink\v1.9.5\third_party\smarty\libs\Smarty.class.php - Line 1263

Checking the gui\templates_c folder showed them to be empty (apart from the various dot files - any particular reason why you are packaging CVS-specific files in a release?) - copying over the contents of D:\Testlink\v1.9.3\gui\templates_c fixed the issue. The download file came from Sourceforge - should gui\templates_c be empty of content?
davidkeaveny
TestLink user
 
Posts: 1
Joined: Wed Sep 19, 2012 7:57 pm
Location: Sydney, Australia

Re: Problem upgrading from 1.9.3 to 1.9.5

Postby fman » Fri Dec 21, 2012 3:51 pm

templates_c is the folder where Smarty Template Engine put result of compilation of .tpl files.
It's ok is empty when you do a fresh install.
please check that all folders are required permissions (write,read, etc) for the user/daemon used to run the webserver process.
fman
Member of TestLink Community
 
Posts: 3063
Joined: Tue Nov 15, 2005 7:19 am


Return to Installation and configuration



Who is online

Users browsing this forum: No registered users and 1 guest