Upgrade SQL query failing - Create Req_Revisions table

Ask community to help.

Moderators: Amaradana, TurboPT, TL Developers

Upgrade SQL query failing - Create Req_Revisions table

Postby SteveyD » Tue Apr 16, 2013 7:54 am

Good Morning all.
Not sure if this is a bug or something incorrect in my DB...
Essentially, I have a 1.9.0 installation. I have got a second server running a carbon copy of the sql (exported/imported) as well as copying all the cfg etc accross.
I am exploring the ease of upgrade. to make sure everything works etc on a test machine before doing a full upgrade on the live system.
Anyawy, cutting to the chase.
Upon attempting to run the Db Schema update (1.9.1) script to the database, I recieve the following error :

08:44:06 CREATE TABLE /*prefix*/req_revisions ( `parent_id` int(10) unsigned NOT NULL, `id` int(10) unsigned NOT NULL, `revision` smallint(5) unsigned NOT NULL default '1', `req_doc_id` varchar(64) NULL, /* it's OK to allow a simple update query on code */ `name` varchar(100) NULL, `scope` text, `status` char(1) NOT NULL default 'V', `type` char(1) default NULL, `active` tinyint(1) NOT NULL default '1', `is_open` tinyint(1) NOT NULL default '1', `expected_coverage` int(10) NOT NULL default '1', `log_message` text, `author_id` int(10) unsigned default NULL, `creation_ts` TIMESTAMP NOT NULL DEFAULT CURRENT_TIMESTAMP, `modifier_id` int(10) unsigned default NULL, `modification_ts` datetime NOT NULL default '0000-00-00 00:00:00', PRIMARY KEY (`id`), UNIQUE KEY /*prefix*/req_revisions_uidx1 (`parent_id`,`revision`) ) DEFAULT CHARSET=utf8 Error Code: 1050. Table 'req_revisions' already exists 0.031 sec
The previous steps of the add columns/add primary key etc all work fine, so not sure if this is a bug, or a bug in my database, or I'm doing something completely dumb on my sql instance (I am completely new to SQl/PHP!)
SteveyD
TestLink user
 
Posts: 7
Joined: Mon Apr 15, 2013 7:49 pm

Re: Upgrade SQL query failing - Create Req_Revisions table

Postby SteveyD » Wed Apr 17, 2013 2:01 pm

Disregard.Fixed now!
SteveyD
TestLink user
 
Posts: 7
Joined: Mon Apr 15, 2013 7:49 pm


Return to Installation and configuration



Who is online

Users browsing this forum: No registered users and 1 guest

cron