Unknown Schema version DB 1.6, please upgrade your Testlink

Ask community to help.

Moderators: Amaradana, TurboPT, TL Developers

Unknown Schema version DB 1.6, please upgrade your Testlink

Postby dbrossard » Thu Jan 23, 2014 9:33 pm

All, I upgrade testlink today from 1.9.7 to 1.9.8. Untarred the files into a new directory and then copied over my working config.inc.php & config_db.inc.php from 1.9.7. According to the README the next steps are:
- Launch TestLink
- TestLink will check Database version, and if some upgrade/migration
is needed will launch automatically the installer.

However when I go to my web page I am unable to login and see an error that states:
"Unknown Schema version DB 1.6, please upgrade your Testlink".

Indeed if I look at my version in Postgres it does not have the new Schema:
Code: Select all
postgres@jira-test:~$ psql testlink
psql (8.4.17)
Type "help" for help.

testlink=# select * from db_version;
 version |        upgrade_ts         |     notes     
---------+---------------------------+----------------
 DB 1.6  | 2013-08-05 22:19:40.02702 | TestLink 1.9.6
(1 row)


I never had TestLink 1.9.6 installed so I assume 1.9.7 used the previous schema.
How do I upgrade the DB scheme. As mentioned I am on Postgres.

Thanks
dbrossard
TestLink user
 
Posts: 1
Joined: Mon Oct 28, 2013 8:20 pm

Re: Unknown Schema version DB 1.6, please upgrade your Testl

Postby fman » Sun Jan 26, 2014 9:18 am

0. we are avoiding any kind of automatic processing of update on installer, may be wrong info is still insider README.

1. give a look to [TLINSTALLDIR]/install/sql/postgres/
there you are going to find the FRESH INSTALL scripts, and will find what is the DB version is expected to be on 1.9.8

2. you can also give a look to [TLINSTALLDIR]/install/sql/alter_tables/1.9.8/postgres
Do a backup of your 1.9.7 DB, and the apply manually these scripts.

3. give a look to other sections of this forum and also on http://mantis.testlink.org, searching for similar upgrade issues.

4. After succesful update, continue your upgrade to 1.9.9 with latest fixes.
fman
Member of TestLink Community
 
Posts: 3063
Joined: Tue Nov 15, 2005 7:19 am


Return to Installation and configuration



Who is online

Users browsing this forum: Bing [Bot] and 2 guests