Configuration problems

Ask community to help.

Moderators: Amaradana, TurboPT, TL Developers

Configuration problems

Postby dvw » Tue Sep 23, 2014 5:18 pm

Hi,

Because i'm a newbie to TL i really hope you can help me.

My setup is RHEL 6.5, Apache 2.2, php 5.5.10, MSSQL 2008r2.
I want to install TL on a Linux machine with a MSSQL db.
The information on the internet to install TL with a MSSQL db is incomplete, so i don't know what to do.
I installed a FreeTDS driver and a unixODBC driver. Then i created a file custom_config.inc.php with the following code
Code: Select all
<?php

//MSSQL database

$myserver = "<testlink_server>:1433/<instancename>";
$myUser = "<TL_user>";
$myPass = "<TL_pw";
$myDB = "<sql_db_name>";

//connection to the database
$dbhandle = mssql_connect($myServer, $myUser, $myPass)
  or die("Couldn't connect to SQL Server on $myServer");

//select a database to work with
$selected = mssql_select_db($myDB, $dbhandle)
  or die("Couldn't open database $myDB");

//declare the SQL statement that will query the database
$query = "SELECT id, name, year ";
$query .= "FROM cars ";
$query .= "WHERE name='BMW'";

//execute the SQL query and return records
$result = mssql_query($query);

$numRows = mssql_num_rows($result);
echo "<h1>" . $numRows . " Row" . ($numRows == 1 ? "" : "s") . " Returned </h1>";

//display the results
while($row = mssql_fetch_array($result))
{
  echo "<li>" . $row["id"] . $row["name"] . $row["year"] . "</li>";
}
//close the connection
mssql_close($dbhandle);
?>

but when i started the installation to access the url http://<tl_server>/testlink the installation starts after "Verification of System and configuration requirements " the install stops.

Is there anyone who can help me please?

With regards
dvw
TestLink user
 
Posts: 1
Joined: Sun Sep 14, 2014 5:03 pm

Return to Installation and configuration



Who is online

Users browsing this forum: No registered users and 4 guests