HOW TO - Solve session config problem

Ask community to help.

Moderators: Amaradana, TurboPT, TL Developers

HOW TO - Solve session config problem

Postby fman » Tue Jan 29, 2008 11:36 am

1. verify on your php.ini or using google where PHP wants to write session info
2. then check if rigths at operation system levels, for user running web server process (IIS process on windows) are ok for the directory.

Following steps can solve your problem:

1. Open file php.ini from your PHP installation folder (example C:\PHP on one windows installation).
2. search for session.save_path and check if this path exists.
3. Checked that the Php\session in the user temp folder didn't exist, so just create it
4. give write permissions on PHP folder to user IUSR_[MACHINE_NAME],
5. restart IIS
6. clear browser cache and cookies
7 try again.
Member of TestLink Community
Posts: 3010
Joined: Tue Nov 15, 2005 7:19 am


Postby » Fri Apr 18, 2008 7:06 am

When i give


It shows me the complete php code in the IE.

I have established MY SQL,DB is done.
IIS is working fine.

Pl let me know the solution.
TestLink user
Posts: 11
Joined: Mon Mar 24, 2008 6:37 am

Session Configuration Failed! (Apache 2, PHP 5)

Postby silvercolt45 » Tue Jan 20, 2009 9:24 pm


I am having trouble getting test link to install properly as I cannot determine why the session configuration is failing. I have verified the following parameters within my php.ini stored within the Apache bin directory of XAMPP on a windows box running XP.

session.save_path = "C:\xampp\tmp" - this directory has read/write permissions set for the user 'everyone'

session.gc_maxlifetime = 1440

Any assistance would be greatly appreciated so I can get this internal demo finished to begin evaluating for production use.
Advanced user
Posts: 33
Joined: Tue Jan 20, 2009 4:57 pm
Location: Las Vegas

Postby Cyrille » Wed Jan 21, 2009 2:32 pm

same problem in my configuration (try to do upgrade from TL 1.7.4 to TL 1.8 RC3) .

i'm using firefox and WAMP (php/apache/mysql) .

Does someone have the solution ?
Advanced user
Posts: 28
Joined: Mon Aug 27, 2007 8:52 am
Location: FRANCE (Brittany)


Postby silvercolt45 » Wed Jan 21, 2009 3:29 pm

I was able to get around this by changing the default session directory in the php.ini file to a newly created directory having all the user rights needed. I am using XAMPP on windows XP.
Advanced user
Posts: 33
Joined: Tue Jan 20, 2009 4:57 pm
Location: Las Vegas

Help Required for Test Link Installation

Postby biju2 » Tue Mar 16, 2010 6:55 pm


Subject: Detail steps for Test Link Installation with Screen Shots

I am new to Test Link group, and have some difficulty in understanding, Section 3: Installation portion of Installation and Configuration Manual. Users, like myself who relies heavily on Installation Wizard’s like Setup.exe to do the installation job find’s little difficult to understand the installation process per manual without screenshot’s.

Follows are the areas, I like to share as a first time user, and hope to get things resolved, based on your valuable and detail feedback with screenshot’s if any.

Downloaded Application: Test Link_1.8.5 and EasyPHP-5.3.2
OS: Window’s Vista
Reference: Installation and Configuration Manual.

Section 3: Installation portion.
1.Install environment: EasyPHP-5.3.2: Successfully Installed.

2.Transfer the Test Link installation file to your web server using whatever method you like best (ftp, scp, etc.). You will need to telnet/SSH access into the server machine for the next steps (if not localhost) :NOT COMPLETED.(waiting for instructions or browsing options in the manual to see installation wizard can do the above step)

After reading the instructions per manual, are we instructing the users should have some basic knowledge on file transfer and telnet commands? ,rather can they simply copy all the .php files under the install folder (part of the download files under testlink_1.8.5 -> testlink-> install->) and paste those under the apache folder (part of the: EasyPHP downloads)

Also observed the following window’s pop-up message: Windows cannot open this file while the user double clicks for e.g.: installStart.php.
Options are
Select a program from a list of installed programs to open the above file
Use the web service to find the correct program

Is the above error has something to do with Window’s Vista OS? resolve the above ?

3.2. AUTOMATIC Installation

TestLink includes installation scripts that help you set-up all mandatory configuration and database structure.

1.From your web browser access http://<yoursite> /
A screenshot on the above steps will be more user friendly, for new user

Finally please look into the above steps and let me know what steps are still missing to successfully launch Test Link.

Thank you.
TestLink user
Posts: 1
Joined: Tue Mar 16, 2010 4:19 pm

Return to Installation and configuration

Who is online

Users browsing this forum: No registered users and 1 guest