start-/end time in user log differs from system time

Ask community to help.

Moderators: Amaradana, TurboPT, TL Developers

start-/end time in user log differs from system time

Postby yuryP » Fri Jul 01, 2016 1:47 pm

please explain me, why "logger.class.php" logs start-/end time in user log file as GTM ( minus two hours from my local time zone).

currently date.timezone parameter in "php.ini" has a value "Europe/Berlin".

Is there a parameter/way to fix this difference ?

thank you for your advice

regards
yuryP
TestLink user
 
Posts: 12
Joined: Thu Jul 30, 2015 6:28 pm

Re: start-/end time in user log differs from system time

Postby fman » Sat Jul 02, 2016 9:56 am

Hi
because you can have users all around the world, the choice for these timestamps has been use a common reference, and not the timezone setted on server.
You can not change this with configuration because gmdate() has been used.
What is not clear is what kind of issue have you found and in what feature.

I'm testing on my laptop with Time Zone Europa/Berlin and see no issue on TestLink event GUI.

regards
fman
Member of TestLink Community
 
Posts: 3021
Joined: Tue Nov 15, 2005 7:19 am

Re: start-/end time in user log differs from system time

Postby yuryP » Mon Jul 04, 2016 7:51 am

thank you for your reply. i understand. it's ok for me.
yuryP
TestLink user
 
Posts: 12
Joined: Thu Jul 30, 2015 6:28 pm


Return to Installation and configuration



Who is online

Users browsing this forum: No registered users and 6 guests