Installing Testlink 1.9.19 on Ubuntu 16.04

Ask community to help.

Moderators: Amaradana, TurboPT, TL Developers

Installing Testlink 1.9.19 on Ubuntu 16.04

Postby fferreira » Tue Jul 23, 2019 11:42 am

Hi everyone, before create this new post, I did a research in order to troubleshoot my blocker, but I didn't find how to fix it.
I'm trying to install Testlink 1.9.19 in a server with:
- Ubuntu 16.04
- Apache/2.4.18 (Ubuntu)
- v7.0.33-0ubuntu0.16.04.5

And in another server I have running mysql 5.7.26-0ubuntu0.16.04.1. I'm not too familiarized with ubuntu.
So, this is the issue that I'm facing: After complete all fields with db connection settings (host, db name, etc..) and pressed on "Procces with testlink setup", I'm getting this error message:

Code: Select all
Creating connection to Database Server:OK!

Connecting to database `testlink`:OK!

 ==============================================================================
 DB Access Error - debug_print_backtrace() OUTPUT START
 ATTENTION: Enabling more debug info will produce path disclosure weakness (CWE-200)
            Having this additional Information could be useful for reporting
            issue to development TEAM.
 ==============================================================================
#0  database->exec_query(SELECT DISTINCT user AS user FROM user) called at [/var/www/html/testlink-code-1.9.19/install/installUtils.php:100]
#1  getUserList(database Object ([db] => ADODB_mysqli Object ([databaseType] => mysqli,[dataProvider] => mysql,[hasInsertID] => 1,[hasAffectedRows] => 1,[metaTablesSQL] => SELECT
         TABLE_NAME,
         CASE WHEN TABLE_TYPE = 'VIEW' THEN 'V' ELSE 'T' END
      FROM INFORMATION_SCHEMA.TABLES
      WHERE TABLE_SCHEMA=,[metaColumnsSQL] => SHOW COLUMNS FROM `%s`,[fmtTimeStamp] => 'Y-m-d H:i:s',[hasLimit] => 1,[hasMoveFirst] => 1,[hasGenID] => 1,[isoDates] => 1,[sysDate] => CURDATE(),[sysTimeStamp] => NOW(),[hasTransactions] => 1,[forceNewConnect] => 1,[poorAffectedRows] => 1,[clientFlags] => 0,[substr] => substring,[port] => 3306,[socket] => ,[_bindInputArray] => ,[nameQuote] => `,[optionFlags] => Array ([0] => Array ([0] => 5,[1] => 0)),[arrayClass] => ADORecordSet_array_mysqli,[multiQuery] => ,[_genIDSQL] => update %s set id=LAST_INSERT_ID(id+1);,[_genSeqSQL] => create table if not exists %s (id int not null),[_genSeqCountSQL] => select count(*) from %s,[_genSeq2SQL] => insert into %s values (%s),[_dropSeqSQL] => drop table if exists %s,[database] => mysql,[host] => "MYSQL SERVER IP ADDRESS",[user] => "MYSQL USER",[password] => not stored,[debug] => ,[maxblobsize] => 262144,[concat_operator] => +,[length] => length,[random] => rand(),[upperCase] => upper,[fmtDate] => 'Y-m-d',[true] => 1,[false] => 0,[replaceQuote] => \',[charSet] => ,[metaDatabasesSQL] => ,[uniqueOrderBy] => ,[emptyDate] =>  ,[emptyTimeStamp] =>  ,[lastInsID] => ,[hasTop] => ,[readOnly] => ,[genID] => 0,[raiseErrorFn] => ,[cacheSecs] => 3600,[memCache] => ,[memCacheHost] => ,[memCachePort] => 11211,[memCacheCompress] => ,[sysUTimeStamp] => ,[noNullStrings] => ,[numCacheHits] => 0,[numCacheMisses] => 0,[pageExecuteCountRows] => 1,[uniqueSort] => ,[leftOuter] => ,[rightOuter] => ,[ansiOuter] => ,[autoRollback] => ,[fnExecute] => ,[fnCacheExecute] => ,[blobEncodeType] => ,[rsPrefix] => ADORecordSet_,[autoCommit] => 1,[transOff] => 0,[transCnt] => 0,[fetchMode] => 2,[null2null] => null,[bulkBind] => ,[_oldRaiseFn] => ,[_transOK] => ,[_connectionID] => ,[_errorMsg] => Access denied for user 'MYSQL USER"@'%' to database 'mysql',[_errorCode] => ,[_queryID] => ,[_isPersistentConnection] => ,[_evalAll] => ,[_affected] => ,[_logsql] => ,[_transmode] => ,[*connectionParameters] => Array ()),[queries_array] => Array (),[is_connected] => ,[nQuery] => 0,[overallDuration] => 0,[dbType] => mysqli,[databaselogEnabled] => 0,[databaselogQueries] => 0), mysql) called at [/var/www/html/testlink-code-1.9.19/install/installUtils.php:268]
#2  create_user_for_db(mysql, testlink, "MYSQL SERVER IP ADDRESS", "MYSQL USER", "MYSQL PASSWORD", admin, admin) called at [/var/www/html/testlink-code-1.9.19/install/installNewDB.php:410]


Thanks in advance, have a great day!
fferreira
TestLink user
 
Posts: 2
Joined: Sun Jul 21, 2019 8:58 am

Re: Installing Testlink 1.9.19 on Ubuntu 16.04

Postby fman » Fri Aug 16, 2019 8:49 am

Hi
have you solved this?
can kindly provide your findings?

regards
fman
Member of TestLink Community
 
Posts: 3063
Joined: Tue Nov 15, 2005 7:19 am

Re: Installing Testlink 1.9.19 on Ubuntu 16.04

Postby TurboPT » Tue Aug 20, 2019 3:19 am

@fman

It looks like there's been a fix to this in Mantis?
I could try an install this weekend, for I do have Ubuntu 16.04. (not sure of the PHP version at the moment, I'm not on that machine)
TurboPT
Member of TestLink Community
 
Posts: 339
Joined: Sun Dec 10, 2006 4:51 am

Re: Installing Testlink 1.9.19 on Ubuntu 16.04

Postby fman » Tue Aug 20, 2019 7:20 pm

@TurboPT
do not use your time for this, we will wait for user feedback
fman
Member of TestLink Community
 
Posts: 3063
Joined: Tue Nov 15, 2005 7:19 am

Re: Installing Testlink 1.9.19 on Ubuntu 16.04

Postby TurboPT » Sat Aug 24, 2019 1:13 am

@fman
Ok, no argument here!
TurboPT
Member of TestLink Community
 
Posts: 339
Joined: Sun Dec 10, 2006 4:51 am


Return to Installation and configuration



Who is online

Users browsing this forum: No registered users and 1 guest

cron