New install 1.9.19 w/ issues

Ask community to help.

Moderators: Amaradana, TurboPT, TL Developers

New install 1.9.19 w/ issues

Postby mkelly19 » Tue Jan 07, 2020 8:38 pm

I have a new installation of 1.9.19 running xampp on win2016. I am currently trying to solve why the user page doesn't load, I tried some things but seem like a whack mole situation, and hoping there is an easier solution.

Here are the things that I have done:

I used these instructions for install: ... lation.htm

After first login encountered:
These changes occur in the

Warning: Creating default object from empty value in C:\xampp\htdocs\Testlink\ on line 844
Resolved with: ini_set('error_reporting', E_ALL);

Attempted some imports:
I also needed to add to declare $tlCfg->resultMatrixReport as part of the standard class:

$tlCfg->resultMatrixReport=new stdClass();

For importing need to modify the defaults
max_execution_time=300 default was 120

$tlCfg->import_file_max_size_bytes = '40960000';
$tlCfg->import_max_row = '100000'; // in chars
$tlCfg->repository_max_filesize = 10; //MB

smaller files work fine larger files have some xml issues.. I can work through those.

When I attempt to load the user page I get:
Fatal error: Uncaught Error: Object of class tlExtTable could not be converted to string in C:\xampp\htdocs\Testlink\gui\templates_c\1130345fece6a6ce888c8cb00a99e832df288f7b_0.file.usersView.tpl.php:51 Stack trace: #0 C:\xampp\htdocs\Testlink\vendor\smarty\smarty\libs\sysplugins\smarty_template_resource_base.php(123): content_5e0f912f2f1ee3_56653548(Object(Smarty_Internal_Template)) #1 C:\xampp\htdocs\Testlink\vendor\smarty\smarty\libs\sysplugins\smarty_template_compiled.php(114): Smarty_Template_Resource_Base->getRenderedTemplateCode(Object(Smarty_Internal_Template)) #2 C:\xampp\htdocs\Testlink\vendor\smarty\smarty\libs\sysplugins\smarty_internal_template.php(216): Smarty_Template_Compiled->render(Object(Smarty_Internal_Template)) #3 C:\xampp\htdocs\Testlink\vendor\smarty\smarty\libs\sysplugins\smarty_internal_templatebase.php(232): Smarty_Internal_Template->render(false, 1) #4 C:\xampp\htdocs\Testlink\vendor\smarty\smarty\libs\sysplugins\smarty_internal_templatebase.php(134): Smarty_Internal_TemplateBase->_execute(Objec in C:\xampp\htdocs\Testlink\gui\templates_c\1130345fece6a6ce888c8cb00a99e832df288f7b_0.file.usersView.tpl.php on line 51

I tried to instantiate $_smarty_tpl=new stdClass(); in teh userassigned and userview.tpl.phps
TestLink user
Posts: 5
Joined: Mon Dec 23, 2019 3:32 pm

Re: New install 1.9.19 w/ issues

Postby mkelly19 » Wed Jan 08, 2020 8:09 pm

Here is the code for line 48-51 from the usersView.tpl.php. When I instantiated $_smarty_tpl in userviews the next error was in userassigned. I could not find tlExtTable in any of the files line on this fatal error.

foreach ($_from as $_smarty_tpl->tpl_vars['idx']->value => $_smarty_tpl->tpl_vars['matrix']->value) {
$_smarty_tpl->tpl_vars['__smarty_foreach_initializer']->value['first'] = !$_smarty_tpl->tpl_vars['__smarty_foreach_initializer']->value['index'];
TestLink user
Posts: 5
Joined: Mon Dec 23, 2019 3:32 pm

Re: New install 1.9.19 w/ issues

Postby mkelly19 » Wed Feb 19, 2020 10:33 pm

I was never able to resolve this installation of 1.9.19-20 I got from

I had no issues with the installation provided by
TestLink user
Posts: 5
Joined: Mon Dec 23, 2019 3:32 pm

Re: New install 1.9.19 w/ issues

Postby fman » Fri Feb 21, 2020 11:23 am

Good to know that you have solved your issue
Member of TestLink Community
Posts: 3091
Joined: Tue Nov 15, 2005 7:19 am

Return to Installation and configuration

Who is online

Users browsing this forum: Majestic-12 [Bot] and 2 guests