Retrieving DevKey from database... possible bug?

Discussion and information for XML-RPC interface.

Moderators: Amaradana, TurboPT, TL Developers

Retrieving DevKey from database... possible bug?

Postby Zhais » Thu Jan 28, 2010 10:54 pm

I'm not entirely sure if this is a bug, or just something screwy with my set up yet.

I started off getting testlink set up for automation with my selenium-rc test cases. I was able to get my dev key just fine, and even checked to ensure it was in the db in the right spot.

Problem is, the xmlrpc script keeps rejecting the dev key. Digging into the code, I found that when it calls

$this->dbObj->fetchFirstRowSingleColumn( $query )

in function _isDevKeyValid, the result is null. I ran the same query in my sql management studio and got the result I wanted (one row with id of '1'), so it is definitely in the database.

I ran the query using dbObj->exec_query( $query ) which returned


however, after running the result through fetch_array (database.class.php), I can not access the value field either by ["id"] or by ["ID"]. I am running sql server 2005, and the xmlrpc version is below.

If anyone knows of a fix, or something I can do to help diagnose this issue let me know!



@version $Revision: $
@modified $Date: 2009/05/02 09:04:30 $ by $Author: franciscom


@version $Revision: $
@modified $Date: 2009/12/09 11:52:29 $ by $Author: havlat

edit: I'm going to piggyback on this post for another oddity:

I'm just bypassing the authentication by having it be true every time, just so I can continue on the project. So the first thing I wanted to see, was to retrieve the list of projects from getProjects().

When I run it, I don't get any errors reported from the xmlrpc class. Instead, what I get are two empty objects representing the two test projects I have in testlink. It's executing the sql query correct it seems, but returning everything w/o initialized values?

Hopefully someone can offer some help for either of the above issues.
TestLink user
Posts: 3
Joined: Wed Jan 06, 2010 9:21 pm

Postby fman » Fri Jan 29, 2010 3:46 pm

NEVER; NEVER use a single post or ISSUE to ask for help on multiple issue. if you consider you have found an issue open it on mantis
Member of TestLink Community
Posts: 3088
Joined: Tue Nov 15, 2005 7:19 am

Postby Zhais » Fri Jan 29, 2010 4:05 pm

Fair enough on multiple questions/issues.

Otherwise, I'm hoping it's not a bug and that I'm just doing something stupid. In which case if it's the latter, definitely would prefer not to fill up a bug report on it :p

edit: after digging around a bit, both problems seem to be stemming from the same issue. Filed a bug report on it~
TestLink user
Posts: 3
Joined: Wed Jan 06, 2010 9:21 pm

Return to XML-RPC API

Who is online

Users browsing this forum: No registered users and 1 guest