Testlink 1.9 beta 4: reportTCResult not updating tcversion

Discussion and information for XML-RPC interface.

Moderators: Amaradana, TurboPT, TL Developers

Testlink 1.9 beta 4: reportTCResult not updating tcversion

Postby tpvn2891 » Mon Jun 07, 2010 3:19 pm

Hello all,

I am a newbie, I use reportTCResult api with all parameters but do not know how to set the tc version, I checked the result in Testlink and it's always the first version reported.

I read in the following link but not found the answer.
http://testlink.org/api/phpdoc_generate ... rtTCResult

Thanks a lot,
TP
tpvn2891
TestLink user
 
Posts: 3
Joined: Wed Jun 02, 2010 4:15 pm

Re: Testlink 1.9 beta 4: reportTCResult not updating tcversi

Postby fman » Mon Jun 07, 2010 6:14 pm

if you consider this an issue please (as stated in FIRST POST on forum) report issue on mantis with detailed steps to reproduce.
Anyway info provided is not enough
fman
Member of TestLink Community
 
Posts: 3061
Joined: Tue Nov 15, 2005 7:19 am

Re: Testlink 1.9 beta 4: reportTCResult not updating tcversi

Postby tpvn2891 » Mon Jun 07, 2010 6:24 pm

Thanks fman,

I was not sure if i missed some points or this is an issue. Is there a way to report TC Result with TC version (through API, reportTCresult)? If not then it's an issue and I will report it.

My basic steps:
1. run API client to report test result: OK. Web interface result showed version 1
2. create a version 2 of the test case, run it manually, Web interface showed version 2
3. run API client again OK. Web interface result still showed version 1

I provided my client with all parameters for reportTCresult method (there is no TC version parameter):
struct $args:
string $args["devKey"]:
int $args["testcaseid"]:
int $args["testplanid"]:
string $args["status"]: - status is $validStatusList
int $args["buildid"]: - optional
string $args["notes"]: - optional
bool $args["guess"]: - optional definiing whether to guess optinal params or require them explicitly default is true (guess by default)

Thanks,
TP
tpvn2891
TestLink user
 
Posts: 3
Joined: Wed Jun 02, 2010 4:15 pm

Re: Testlink 1.9 beta 4: reportTCResult not updating tcversi

Postby fman » Tue Jun 08, 2010 5:45 am

Confirmed issue, please create issue on mantis with details you have done here, do not put just link to forum.
fman
Member of TestLink Community
 
Posts: 3061
Joined: Tue Nov 15, 2005 7:19 am

Re: Testlink 1.9 beta 4: reportTCResult not updating tcversi

Postby tpvn2891 » Wed Jun 09, 2010 3:31 pm

Issue reported: ID 0003511.
Thanks.
tpvn2891
TestLink user
 
Posts: 3
Joined: Wed Jun 02, 2010 4:15 pm

Re: Testlink 1.9 beta 4: reportTCResult not updating tcversi

Postby fman » Wed Jun 09, 2010 4:09 pm

solution has been comitted to CVS
I will try to create a fix that will be attached to issue on mantis
fman
Member of TestLink Community
 
Posts: 3061
Joined: Tue Nov 15, 2005 7:19 am


Return to XML-RPC API



Who is online

Users browsing this forum: No registered users and 2 guests