[SOLVED-PHP.ini] Not All Test Cases are added to Test Plan

LATEST Official version.
Questions and discussions - NO ISSUES
FOR ISSUES => http://mantis.testlink.org

Moderators: Amaradana, TurboPT, TL Developers

[SOLVED-PHP.ini] Not All Test Cases are added to Test Plan

Postby mtavares » Wed Dec 12, 2012 7:50 pm

Hello,

I have tried to add multiple testcases to a test plan in Both 1.9.4 and 1.9.5. There seems to be a Limit of 415 Test Cases that can be added to a plan at one time. Do you know where this Limit is being set? Here are my steps to reproduce:

We have 6 Web Browser Versions listed as "Platforms".

I Click Add Test Cases to Test Plan.
I Select a Folder in the Test Case Tree with 150 Testcases.
I Select All Test Cases and I Select All Platforms.
I verify all Test Cases are Checked and I Click Add Selected.

Results:

I Scroll to the bottom and Notice a bunch of test cases are not highlighted. I go to the Test Plan and Notice only 415 Testcases were added.

There should have been 6*150 = 900 test cases added. This limit is also enforced, when assigning the test cases to a tester.
mtavares
TestLink user
 
Posts: 9
Joined: Sat Oct 13, 2012 3:01 pm

Re: Not All Test Cases are being added to Test Plan

Postby fman » Wed Dec 12, 2012 8:38 pm

there is no limit, after some tests on our demo site IMHO issue is related to AMOUNT OF DATA webserver or/and browser handle when we submit the page. NOT ALL SELECTED CHECBOXES arrives via $_REQUEST (PHP variable).
Can not reproduce on my ALL LOCAL (LAMPP ) installation.
Can you give some look to you webserver configuration and logs ?
fman
Member of TestLink Community
 
Posts: 3014
Joined: Tue Nov 15, 2005 7:19 am

Re: Not All Test Cases are being added to Test Plan

Postby mtavares » Thu Dec 13, 2012 12:22 am

Hello,

Our Server is a RHEL Lamp install. It has PHP 5.3.18 and apache 2.2.3.

We have reproduced the issue on three server and in every case we hit the 414 limit.

The PlanAddTC.php get size is 692.80k it looks like the client/browser is sending all the TCs correctly. Is there a php.ini or apache config setting that we could change? Is there any specific information I can provide you?

access logs:

nk/lib/plan/planAddTC.php?print_scope=test_specification&edit=testsuite&level=testsuite&id=535&form_token=2073164686&" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.95 Safari/537.11"

10.68.42.218 - - [12/Dec/2012:18:10:57 -0500] "GET /testlink/gui/themes/default/images//disconnect.png HTTP/1.1" 200 796 "http://testlink701.epnet.com/testlink/lib/plan/planAddTC.php?print_scope=test_specification&edit=testsuite&level=testsuite&id=535&form_token=2073164686&" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.95 Safari/537.11"

10.68.42.218 - - [12/Dec/2012:18:10:57 -0500] "GET /testlink/gui/themes/default/images//date.png HTTP/1.1" 200 626 "http://testlink701.epnet.com/testlink/lib/plan/planAddTC.php?print_scope=test_specification&edit=testsuite&level=testsuite&id=535&form_token=2073164686&" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.95 Safari/537.11"

10.68.42.218 - - [12/Dec/2012:18:10:55 -0500] "POST /testlink/lib/plan/planAddTC.php?print_scope=test_specification&edit=testsuite&level=testsuite&id=535&form_token=2073164686& HTTP/1.1" 200 713941 "http://testlink701.epnet.com/testlink/lib/plan/planAddTC.php?print_scope=test_specification&edit=testsuite&level=testsuite&id=535&form_token=2073164686&" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.95 Safari/537.11"
mtavares
TestLink user
 
Posts: 9
Joined: Sat Oct 13, 2012 3:01 pm

Re: Not All Test Cases are being added to Test Plan

Postby fman » Thu Dec 13, 2012 8:04 am

>> Is there a php.ini or apache config setting that we could change? Is there any specific information I can provide you?
Unfortunately no, I've done some searches on goggle but without luck.
I need YOUR effort on this. Anyway I will try to refine my searches.

As stated with ALL SERVERS on same machine (my laptop) issue do not exist, but I do not what is the limit on my LAMPP installation
fman
Member of TestLink Community
 
Posts: 3014
Joined: Tue Nov 15, 2005 7:19 am

Re: Not All Test Cases are being added to Test Plan

Postby fman » Thu Dec 13, 2012 9:04 pm

fman
Member of TestLink Community
 
Posts: 3014
Joined: Tue Nov 15, 2005 7:19 am

Re: Not All Test Cases are being added to Test Plan

Postby mtavares » Thu Dec 13, 2012 10:35 pm

Thanks for the help.

I fixed it by doing the following:

In php.ini I changed max_input_vars = 1000 to max_input_vars = 10000
mtavares
TestLink user
 
Posts: 9
Joined: Sat Oct 13, 2012 3:01 pm

Re: [SOLVED-PHP.ini] Not All Test Cases are added to Test P

Postby fman » Fri Dec 14, 2012 7:19 pm

Just for the records:
with LAMPP 1.7.7 I was unable to reproduce this, but after upgrading to 1.8.1, voila! TL crashed on this feature.
Changes from 1.7.7 to 1.8.1 on apache and php has to be the reason.

CONFIRMED - adding: max_input_vars = 10000 into php.ini SOLVED THE ISSUE

Need to understand relation between amount of test cases and this number.
tests:
Test Suite with 404 test cases, trying to add ALL to test plan:

max_input_vars = 1000 => only 198 test cases are added
Fortunately GOT WARNING ON test link screen:
Warning: Unknown: Input variables exceeded 1000. To increase the limit change max_input_vars in php.ini. in Unknown on line 0

max_input_vars = 2000 => Can ADD all (404), but can not remove ALL
max_input_vars = 3000 => ALL worked OK.

TESTED with PHP 5.3.9
fman
Member of TestLink Community
 
Posts: 3014
Joined: Tue Nov 15, 2005 7:19 am

Re: Not All Test Cases are being added to Test Plan

Postby fortcwb » Thu Aug 24, 2017 2:58 pm

mtavares wrote:Thanks for the help.

I fixed it by doing the following:

In php.ini I changed max_input_vars = 1000 to max_input_vars = 10000


Just to record. This totally worked for me.
fortcwb
TestLink user
 
Posts: 6
Joined: Thu Jun 30, 2011 6:33 pm


Return to TestLink 1.9



Who is online

Users browsing this forum: No registered users and 1 guest