Page 1 of 1

[SOLVED] Unable to Assign Testers to test execution

PostPosted: Wed Dec 10, 2014 11:35 am
by maxveneziano
On TL 1.9.12 WITHOUT ANY FIX
I've created a Project
Created a Requirement
Created a Test Case
Created a Test Suite
Defined a Test Plan
Defined a Build
Assigned two users (Senior Test and Admin) to both Project and TP

It is correctly shown the Project/Test Plan/Test Suite (1)/Test Case in the Navigator - Test Specification panel

But in
Test Plan Contents -> Assign Test Case Execution there is no way to assign a Test case to a user.
The Assign Test Case left navigation panel shows the correct Test Plan and the correct Build . The filter shows a structure with the Project name/Test Plan name (1) but is not possible to expand the element to a lowe level to select a Test case.

On the right panel it is shown Assign Testers to test execution with instructions (Purpose and Get Started). No Icons at all. Any possibility to interact.

In addition selecting Test Plan Contents -> Add / Remove Test Cases it is possible to select a Test Case From the Test Suite.
But in the right panel
TEST Plan : Test Plan name - Add/Remove Test Cases to/from Test Plan
it is listed the Test Case BUT it is not possible to Assign to user on add
I provide the proposed names but the System doesn't associate to a TC and this is confirmed in
Test Execution -> Execute test. Selecting the test case, it is declared No tester Assigned

Unfortunately nobody highlighted this issue before on the TL forum.
Any suggestion ?
Maybe a configuration problem ?

Thanks in advance
Massimo

Re: Unable to Assign Testers to test execution

PostPosted: Wed Dec 10, 2014 3:05 pm
by fman
Just few words about communication channels

1. Forum is not for issues => use mantis
1.1 Before reporting an issue check for similar one removing status filter
1.2 provide complete steps => Create Test project => no good. Create Test Project TPROJ-01, active and public => GOOD
1.3 get latest code from gitorious (branch 1.9.13), install on sandbox and retest.
1.4 Have you tried on demo.testlink.org ?


2. Mantis is not for asking questions => use forum

Re: Unable to Assign Testers to test execution

PostPosted: Thu Dec 11, 2014 5:04 pm
by maxveneziano
Hi Francisco,
thank for your fast reply. Before to declare a bug I need to be sure that's not a my fault.
1.3 Anyway I confirm you that after installing the version 1.9.13 the issue has bees solved.
1.4 It's ok also on demo.testlink.org
Then I can suppose that's a bug of 1.9.12

Re: [SOLVED] Unable to Assign Testers to test execution

PostPosted: Thu Dec 11, 2014 6:04 pm
by fman
Right path is ALWAYS check if there are fixes, then fresh install with latest fixes, and retest
This procedure will save time to all us.