[SOLVED] Bug Management icon is missing on 1.9.13

LATEST Official version.
Questions and discussions - NO ISSUES
FOR ISSUES => http://mantis.testlink.org

Moderators: Amaradana, TurboPT, TL Developers

[SOLVED] Bug Management icon is missing on 1.9.13

Postby bestc » Wed Jun 03, 2015 7:50 am

Hi,

I'm new with this tool and trying to setup Testlink.
Bug management icon is missing on the Teslink 1.9.13 after installing and configuring.

Please find below for the image or link for more info regarding the query.

https://drive.google.com/file/d/0Bwa2Ikku736pbUJGazBNQnZzQjg/view?usp=sharing
Image
bestc
TestLink user
 
Posts: 10
Joined: Tue Jun 02, 2015 7:14 pm

Re: Bug Management icon is missing on 1.9.13

Postby fman » Wed Jun 03, 2015 1:31 pm

fman
Member of TestLink Community
 
Posts: 3073
Joined: Tue Nov 15, 2005 7:19 am

Re: Bug Management icon is missing on 1.9.13

Postby bestc » Thu Jun 04, 2015 2:05 am

i think issue tracker configuration is already configured correctly as per on example but still unable to see the bug management icon.
by the way, i'm using MantisBT to integrate on Testlink.
bestc
TestLink user
 
Posts: 10
Joined: Tue Jun 02, 2015 7:14 pm

Re: Bug Management icon is missing on 1.9.13

Postby bestc » Thu Jun 04, 2015 3:22 am

i also noticed that on lib\issuetrackerintegration\mantisdbInterface.class.php that completeCfg is missing.
bestc
TestLink user
 
Posts: 10
Joined: Tue Jun 02, 2015 7:14 pm

Re: Bug Management icon is missing on 1.9.13

Postby fman » Thu Jun 04, 2015 6:03 am

1) details provided are not enough to do any check.
steps to reproduce scenario have not been provided

2) do not dig the code to look for errors because you need to understand whole architecture.
because
mantisdbInterface extends issueTrackerInterface

the method you said does not exist can be present on extended class

IMHO one reason can be that have not configured link between issue tracker and test project.
You have not provided any feedback about this, just said: all config is ok, that does not help
fman
Member of TestLink Community
 
Posts: 3073
Joined: Tue Nov 15, 2005 7:19 am

Re: Bug Management icon is missing on 1.9.13

Postby bestc » Thu Jun 04, 2015 8:01 am

Thank you for your response. You're right!

I got an error:
Attention Please:
Something is preventing connection to Bug Tracking System,
and is going to create performance issues.
Please contact your TestLink Administrator


Testlink and Mantisbt are setup on a different servers:

Issue tracker configuration are provided. Still the same way of configuration if using different servers?

Thank you for your patience.
bestc
TestLink user
 
Posts: 10
Joined: Tue Jun 02, 2015 7:14 pm

Re: Bug Management icon is missing on 1.9.13

Postby fman » Thu Jun 04, 2015 8:45 am

still working blind => no way to help
config is always the same
give a look to TestLink logs
fman
Member of TestLink Community
 
Posts: 3073
Joined: Tue Nov 15, 2005 7:19 am

Re: Bug Management icon is missing on 1.9.13

Postby bestc » Thu Jun 04, 2015 8:56 am

tnx for the info. as i look at the log... i provided the incorrect user. After i provided the correct dbuser it's already working fine. Thank you a lot.
bestc
TestLink user
 
Posts: 10
Joined: Tue Jun 02, 2015 7:14 pm


Return to TestLink 1.9



Who is online

Users browsing this forum: No registered users and 6 guests