Unable to send email notification from testlink (1.9.16)

LATEST Official version.
Questions and discussions - NO ISSUES
FOR ISSUES => http://mantis.testlink.org

Moderators: Amaradana, TurboPT, TL Developers

Unable to send email notification from testlink (1.9.16)

Postby ashmon » Mon Feb 13, 2017 9:45 pm

Hi,

I installed the latest Testlink version (1.9.16) and I'm having issues with sending email notifications from Testlink. It occurs when I go into the user management section and attempt to reset password of a user. It also occurs when I try to assign a test case to a specific tester. Here is repro steps:

1. I login as admin
2. I got to user management section
2. I select user that I want to reset password
3. I click on reset password button

Result:

The webpage waits for server response for about 5 minutes or returns a blank page right away. After the 5 minutes, I remain on the same page and nothing happens. No email sent to user.

I'm hoping this has to with my configuration to connect to our corporate microsoft exchange server. Here is the config I have in config.inc.php file:

/**
* @var string SMTP server name or IP address ("localhost" should work in the most cases)
* Configure using custom_config.inc.php
* @uses lib/functions/email_api.php
*/
$g_smtp_host = '[microsoft exchange server host name]'; # SMTP server MUST BE configured

# Configure using custom_config.inc.php
$g_tl_admin_email = '[corporate email]'; # for problem/error notification
$g_from_email = '[corporate email]'; # email sender
$g_return_path_email = '[corporate email]';

/**
* Email notification priority (low by default)
* Urgent = 1, Not Urgent = 5, Disable = 0
**/
$g_mail_priority = 5;

/**
* Taken from mantis for phpmailer config
* select the method to mail by:
* PHPMAILER_METHOD_MAIL - mail()
* PHPMAILER_METHOD_SENDMAIL - sendmail
* PHPMAILER_METHOD_SMTP - SMTP
*/
$g_phpMailer_method = PHPMAILER_METHOD_SMTP;

/** Configure only if SMTP server requires authentication */
$g_smtp_username = '[corporate user name]'; # user
$g_smtp_password = '[corporate password]'; # password

/**
* This control the connection mode to SMTP server.
* Can be '', 'ssl','tls'
* @global string $g_smtp_connection_mode
*/
$g_smtp_connection_mode = 'ssl';

/**
* The smtp port to use. The typical SMTP ports are 25 and 587. The port to use
* will depend on the SMTP server configuration and hence others may be used.
* @global int $g_smtp_port
*/
$g_smtp_port = 443;


/**
* @see https://github.com/PHPMailer/PHPMailer/ ... leshooting
* Opportunistic TLS
*/
$g_SMTPAutoTLS = false;


Any help would be greatly appreciated as it's blocking me right now from resetting passwords.
ashmon
TestLink user
 
Posts: 11
Joined: Wed Sep 09, 2015 6:33 pm

Return to TestLink 1.9



Who is online

Users browsing this forum: No registered users and 4 guests