Failed upgrade from 16 to 17

LATEST Official version.
Questions and discussions - NO ISSUES

Moderators: Amaradana, TurboPT, TL Developers

Failed upgrade from 16 to 17

Postby vma » Fri Dec 07, 2018 8:23 am


today I tried to upgrade from 1.9.14 to 1.9.18 via incremental steps and the upgrade did not work well.
Upgrade from 14 to 15 worked OK.
Upgrade from 15 to 16 worked OK.
During upgrade from 16 to 17 I hit this issue
mysql testlink < install/sql/alter_tables/1.9.17/mysql/DB.1.9.17/step1/db_schema_update.sql
ERROR 1146 (42S02) at line 35: Table 'testlink.latest_tcase_version_number' doesn't exist

I tried to continue and I hit another issue in upgrade from 17 to 18
mysql testlink < install/sql/alter_tables/1.9.18/mysql/DB.1.9.18/step1/db_schema_update.sql
ERROR 1060 (42S21) at line 9: Duplicate column name 'id'

Any idea how can I fix this?
TestLink user
Posts: 2
Joined: Sat Jul 09, 2016 9:00 am

Re: Failed upgrade from 16 to 17

Postby larsen » Sun Dec 16, 2018 3:04 pm

If you're not an expert (like me) I recommend to make a local copy; dump the database and copy the upload area and then install on a localhost and play around. I managed to upgrade from 1.9.16 to 1.9.18 that way.
And phpmyadmin is a good tool to view your database.

latest_tcase_version_number is a view?
Around line 35 it creates table testcase_script_links? Sounds that you have a corrupt or wrong script file?
I guess if you run the script a second time, you will run into creation problems.

I wouldn't try 18 until 17 is running, I think a partial 18-update may end up 17 not run?
How's your database look likes?

(Maybe I just proved that I'm not an expert)
/ L
TestLink user
Posts: 13
Joined: Sun May 28, 2017 6:29 pm

Return to TestLink 1.9

Who is online

Users browsing this forum: Majestic-12 [Bot] and 6 guests