TestLink Setup error

The release 1.6 is going to be unsupported by Community. Because our effort moves ahead. However there are still valuable informations for you.

TestLink Setup error

Postby prabhat » Thu Apr 26, 2007 8:50 am

I had installed testlink 1.6 + PHP 4.4.6 + Mysql 5.0.

Still i am getting the following error:

Checking PHP version:
Failed! - You are running on PHP 4.4.6, and TestLink requires PHP 5.0.0 or greater


Warning!: You are using a M$ Operating System, be careful with authentication problems
between PHP 4 and the new MySQL 4.1.x passwords
Read this MySQL - A.2.3. Client does not support authentication protocol

Checking if Register Globals = OFF: OK!
Checking if sessions are properly configured: OK!
Checking if ../gui/templates_c directory exists: OK!
Checking if ../gui/templates_c directory is writable: OK!
Warning: check_pear_modules(Spreadsheet/Excel/Writer.php) [function.check-pear-modules]: failed to open stream: No such file or directory in C:\Program Files\Apache Group\Apache2\htdocs\testlink\install\installUtils.php on line 559

Warning: check_pear_modules() [function.include]: Failed opening 'Spreadsheet/Excel/Writer.php' for inclusion (include_path='.;c:\php4\pear') in C:\Program Files\Apache Group\Apache2\htdocs\testlink\install\installUtils.php on line 559

Checking if PEAR modules are installed:Failed! - Spreadsheet_Excel_Writer PEAR Module is required.
Seehttp://pear.php.net/package/Spreadsheet_Excel_Writer for additional information

Unfortunately, TestLink setup cannot continue at the moment, due to the above 2 errors . Please correct the errors, and try again. If you need help figuring out how to fix the problems, please read the documentation in the TestLink Wiki, or visit the TestLink Forums.

-. According to me testlink 1.6 supports php 4.4, so what could be the reason
prabhat
Advanced user
 
Posts: 19
Joined: Wed Apr 18, 2007 11:37 am

Postby fman » Thu Apr 26, 2007 3:09 pm

Spreadsheet module needs PHP5
fman
Member of TestLink Community
 
Posts: 3010
Joined: Tue Nov 15, 2005 7:19 am

Postby prabhat » Fri Apr 27, 2007 3:41 am

ok, then should i need to install PHP5 for testlink 1.6.
Is there any other way of solving this prob?
prabhat
Advanced user
 
Posts: 19
Joined: Wed Apr 18, 2007 11:37 am

Postby fman » Fri Apr 27, 2007 12:25 pm

hack the install code (very simple) to avoid check for pear
fman
Member of TestLink Community
 
Posts: 3010
Joined: Tue Nov 15, 2005 7:19 am


Return to TestLink 1.6 (closed)



Who is online

Users browsing this forum: No registered users and 1 guest