Testlink performance

The release related discussions, plans and questions.

Testlink performance

Postby krishnas » Wed May 02, 2007 12:15 pm

Hi,
We have been using Testlink for the last 6 months.
Thanks for the wonderfull tool.

Currently we are using 1.6.2. We have about 3 products and each product has about 20,000 test cases. We see that TL is very slow when we navigate to Specifications menu.

We wanted to migrate to 1.7 but fearing TL performance we have not yet migrated to 1.7.

I have few quiries on teh performance:
1. Is it advisable to migrate to 1.7 with this much amount of data.
2. Other option we though of was to change the tree structure for specification screen wherein when specification is selecetd only components asossiated with that product (do not list category and test case total).
OR is there any other way to improve teh performance. Please advise.
krishnas
Advanced user
 
Posts: 15
Joined: Mon Nov 06, 2006 8:18 am

Postby mch423 » Wed May 02, 2007 5:32 pm

We are also experiencing the same problem but with only 4,000 test cases on 1.7RC2. Loading of the tree takes over 2 minutes and what is worse is that it redraws the entire tree when updating. This makes the product unusable. I would recommend implementing lazy loading and make AJAX calls to retrieve the needed node when clicked on.

I love the simplicity of the product but unfortunately this one single drawback may kill our use of it. Hopefully the Testlink team is reading this.

- Max
mch423
TestLink user
 
Posts: 3
Joined: Tue May 01, 2007 10:00 pm

Postby Liffus » Thu May 03, 2007 6:24 am

i have tried the tree with nearly 20k testcases in one project and it takes about 7 secounds to update the tree.
Regards,
Leif
Liffus
TestLink user
 
Posts: 6
Joined: Fri Apr 13, 2007 10:07 am
Location: Germany

Postby krishnas » Thu May 03, 2007 6:29 am

Hi Liffus,
That sounds great. Can you please share what tree you are using and also let us know if you have done any changes.
krishnas
Advanced user
 
Posts: 15
Joined: Mon Nov 06, 2006 8:18 am

Postby Liffus » Thu May 03, 2007 6:32 am

We use jtree and we have done no changes in 1.7 RC2.

Regards,
Leif
Liffus
TestLink user
 
Posts: 6
Joined: Fri Apr 13, 2007 10:07 am
Location: Germany

Postby krishnas » Thu May 03, 2007 6:34 am

Hi,
Thanks for the quick response.
Have you used 1.6.X if so did you find improvement in performance when you migrated to 1.7 RC2
krishnas
Advanced user
 
Posts: 15
Joined: Mon Nov 06, 2006 8:18 am

Postby Liffus » Thu May 03, 2007 6:36 am

We started with 1.7 RC1 for tests and have updated to 1.7 RC2. We have not used 1.6 versions.

Regards,
Leif
Liffus
TestLink user
 
Posts: 6
Joined: Fri Apr 13, 2007 10:07 am
Location: Germany

analysis and solution

Postby lshiva86 » Thu Nov 13, 2008 4:22 am

lshiva86
Advanced user
 
Posts: 20
Joined: Mon Sep 15, 2008 5:52 am

Test LInk Performance issue

Postby krishnapriya_83 » Thu Mar 19, 2009 1:36 pm

Hi ,

We are using Test Link 1.7.5 on LINUX .
No of Test cases are around 4000.
While loading the tree its taking around 3 mins

We dont know PHP .
Please share the code and the procedure which solves this performance issue

Thanks,
Priya
krishnapriya_83
TestLink user
 
Posts: 3
Joined: Thu Mar 19, 2009 1:32 pm

Postby rajprasa » Mon Jun 08, 2009 6:50 pm

Hi Priya,

Could you pls update if u resolved this issue ?

Thanks,
Rj
rajprasa
TestLink user
 
Posts: 14
Joined: Wed Jan 21, 2009 1:28 am

Postby krishnapriya_83 » Tue Jun 09, 2009 4:01 am

no
krishnapriya_83
TestLink user
 
Posts: 3
Joined: Thu Mar 19, 2009 1:32 pm


Return to TestLink 1.7 (Closed)



Who is online

Users browsing this forum: No registered users and 3 guests