Migration problem from 1.9.14 to 1.9.15

Moderators: Amaradana, TurboPT, TL Developers

Migration problem from 1.9.14 to 1.9.15

Postby bestc » Mon Nov 07, 2016 2:04 am

Hi,

I got an error below when executing install\sql\alter_tables\1.9.15\mysql\DB.1.9.15\step1db_schema_update.sql

===============================================
SCRIPT:
CREATE TABLE /*prefix*/plugins (
`id` int(11) NOT NULL auto_increment,
`basename` varchar(100) NOT NULL,
`enabled` tinyint(1) NOT NULL default '0',
`author_id` int(10) unsigned default NULL,
`creation_ts` datetime NOT NULL DEFAULT CURRENT_TIMESTAMP,
PRIMARY KEY (`id`)
) DEFAULT CHARSET=utf8;

CREATE TABLE /*prefix*/plugins_configuration (
`id` int(11) NOT NULL auto_increment,
`testproject_id` int(11) NOT NULL,
`config_key` varchar(255) NOT NULL,
`config_type` int(11) NOT NULL,
`config_value` varchar(255) NOT NULL,
`author_id` int(10) unsigned default NULL,
`creation_ts` datetime NOT NULL DEFAULT CURRENT_TIMESTAMP,
PRIMARY KEY (`id`)
) DEFAULT CHARSET=utf8;
=============================================================================

ERROR:
<e>Query: CREATE TABLE plugins ( `id` int(11) NOT NULL auto_increment, `basename` varchar(100) NOT NULL, `enabled` tinyint(1) NOT NULL def...

Error Code: 1067
Invalid default value for 'creation_ts'

Execution Time : 0 sec
Transfer Time : 0 sec
Total Time : 0 sec
--------------------------------------------------

Query: CREATE TABLE plugins_configuration ( `id` int(11) NOT NULL auto_increment, `testproject_id` int(11) NOT NULL, `config_key` varch...

Error Code: 1067
Invalid default value for 'creation_ts'

Execution Time : 0 sec
Transfer Time : 0 sec
Total Time : 0 sec

Thank you,
Chelito
bestc
TestLink user
 
Posts: 10
Joined: Tue Jun 02, 2015 7:14 pm

Re: Migration problem from 1.9.14 to 1.9.15

Postby alm_pro » Tue Jun 06, 2017 10:41 pm

I'm experiencing the same problem. We made sure the MySQL db was upgraded to the required 5.6.x level but the error persists and is preventing completion of the upgrade. Could it be that CURRENT_TIMESTAMP is coming back all zeros for some reason and that's not allowed?

Any suggestions on a workaround would be appreciated.
alm_pro
TestLink user
 
Posts: 4
Joined: Sun May 21, 2017 9:32 am

SOLVED Re: Migration problem from 1.9.14 to 1.9.15

Postby alm_pro » Thu Jun 08, 2017 4:25 pm

Turns out the upgrade to MySQL hadn't gotten the system all the way up to 5.6. The post viewtopic.php?f=1&t=8011 helped to make it clear that we needed to be at MySQL 5.6.5 or greater. After upgrading MySQL to 5.6.36 the upgrade sql scripts completed successfully.
alm_pro
TestLink user
 
Posts: 4
Joined: Sun May 21, 2017 9:32 am


Return to Upgrade



Who is online

Users browsing this forum: No registered users and 2 guests