Performance by creating reports very bad

1.8 related questions and discussions.
Please upgrade to LATEST 1.9.x.
No more fixes for 1.8.

Moderators: Amaradana, TurboPT, TL Developers

Performance by creating reports very bad

Postby Markus » Thu Aug 28, 2008 6:16 am

now I have a little bit more experience with Testlink and I must say very nice tool !!

But I have some problems with performance and this is a blocking point for
me.

In my database I have currently 2800 Testcases.
I had/have the following problems with performance:

- loading Specification/Execution/report side was very slow => this was solved by me to switch to another SQL server (please note, that with MSSQL your system will be very slow)

- creation of reports are very, very slow (I wait 5 min to get an testreport, which is definitly to much). I have done the same with testlink 1.7.4 and there it takes 10 sec !!

Is there any workarounds/fixes e.g. available?
Markus
Advanced user
 
Posts: 17
Joined: Thu Aug 21, 2008 6:39 am

Postby fman » Thu Aug 28, 2008 7:41 am

>> loading Specification/Execution/report side was very slow => this was >> solved by me to switch to another SQL server (please note, that with >> MSSQL your system will be very slow)

Thanks for this info.
Just for the record our main DB is MySQL.
Maybe problems with MSSQL are related to ADODB.
Is VERY important to know what DB server are you using now.


>> creation of reports are very, very slow (I wait 5 min to get an
>> testreport, which is definitly to much). I have done the same with
>> testlink 1.7.4 and there it takes 10 sec !!
In order to help we need to have more information.
Is possible for you to send us a dump of your db to do some tests?

>> Is there any workarounds/fixes e.g. available?
Always You have two places where to chooe a solution:
- Mantis issue tracker
- this forum

Because problem has not been reported before on Mantis we do not have any fix.
fman
Member of TestLink Community
 
Posts: 3024
Joined: Tue Nov 15, 2005 7:19 am

Performance by creating reports very bad

Postby Markus » Thu Aug 28, 2008 9:04 am

Please find dumpfile attached
Markus
Advanced user
 
Posts: 17
Joined: Thu Aug 21, 2008 6:39 am

Postby fman » Thu Aug 28, 2008 10:44 am

do not see attached file

would you mind to send (zipped file) to francisco.mancardi@gmail.com ?
fman
Member of TestLink Community
 
Posts: 3024
Joined: Tue Nov 15, 2005 7:19 am


Return to TestLink 1.8 (OBSOLETE => EOL)[LOCKED]



Who is online

Users browsing this forum: No registered users and 9 guests