gforge support

1.8 related questions and discussions.
Please upgrade to LATEST 1.9.x.
No more fixes for 1.8.

Moderators: Amaradana, TurboPT, TL Developers

gforge support

Postby Gilbert » Tue Oct 07, 2008 6:18 pm

Hi,

Does Testlink support gforge ?
If so, where am I supposed to find some confguration examples and.or tips ?
If not, is this planned in the near future ?

Thanks
Gilbert
TestLink user
 
Posts: 1
Joined: Tue Oct 07, 2008 6:14 pm

Also interested in GForge Support

Postby silvercolt45 » Tue Jan 20, 2009 5:00 pm

Does the current API support integration with GForge? Is there anyone who has implemented bug tracking by gforge into Test Link. I am just now starting to investigate the possibilities of use Test Link for our small QA team (currently we use a messy spreadsheet to manage test cases). However the entire company use Gforge for project, development and bug management. So for Test Link to be a success i will need someway to integrate bugs found in executing test link test cases into gforge. We also have started implementing test automation using Cruise Control and Selenium.
silvercolt45
Advanced user
 
Posts: 33
Joined: Tue Jan 20, 2009 4:57 pm
Location: Las Vegas

Postby fman » Tue Jan 20, 2009 6:04 pm

supported on 1.8 RC3
fman
Member of TestLink Community
 
Posts: 3062
Joined: Tue Nov 15, 2005 7:19 am

Documentation

Postby silvercolt45 » Tue Jan 20, 2009 6:07 pm

Thank you! for the quick response. Is there current documentation to review for implementation of the gforge integration? Or is it the same as the other bug tracking instructions only using "gforge" as the tracker name?

Again thank you for your assistance!
silvercolt45
Advanced user
 
Posts: 33
Joined: Tue Jan 20, 2009 4:57 pm
Location: Las Vegas

Postby silvercolt45 » Thu Jan 22, 2009 8:18 pm

I need help in identifying why my current install of testlink 1.8 RC3 is not connecting to the gforge database. I have verified the database connection string provided by my DBA is functioning and is not being blocked by my testlink server. So I think there is something not right within testlink config that I am missing somewhere. can someone please direct me on what information one would need to assist in trouble shooting this issue? Thank you!

I have been editing the /cfg/gforge.cfg.php file adding in the host (tried server name and IP address) the gforge database (gforge5) the username and password. what else is there in order to get connected? Shall I place the port # in the host string i.e. 'XX.XX.XX.XX:5432'

FYI - PG version being used is 7.4
silvercolt45
Advanced user
 
Posts: 33
Joined: Tue Jan 20, 2009 4:57 pm
Location: Las Vegas

Please Help!

Postby silvercolt45 » Fri Jan 23, 2009 6:22 pm

I don't mean to be pushy here, I am under a deadline to get Testlink evaluated so we can start using it in production or look else where (I believe testlink is our answer). However, I cannot get the gForge integration working due to the previously stated reasons. I have searched the forums and documentation and unfortunately cannot find anything that addresses my problem. can someone please assist today?

Thank you :!:
silvercolt45
Advanced user
 
Posts: 33
Joined: Tue Jan 20, 2009 4:57 pm
Location: Las Vegas

Postby fman » Mon Jan 26, 2009 4:45 pm

I've connected without problems using gforge installed on virtual machine
what kind of error do you got ?

Look on our mantis for gforge contribution to contact user that has develop it
fman
Member of TestLink Community
 
Posts: 3062
Joined: Tue Nov 15, 2005 7:19 am

Error MEssage

Postby silvercolt45 » Mon Jan 26, 2009 5:03 pm

fman,

Thanks for the reply! Here are the error messages I am seeing (not sure if there are more places to look)

Message header in main application window
* There are warnings on your configuration
* See details on file: /var/www/testlink/logs/config_check.txt
Connection to your Bug Tracking System has failed:<br>
Please check your configuration.<br>
Be careful this problem will degrade the TestLink performance.

Found within the Events window of the main application

01/26/2009 08:50:33 ERROR Connect to Bug Tracker database fails!!! -24 - -24

I have verified the gforge database credentials as working. here is a copy of my gforge.cfg.php

Code: Select all
/** The DB host to use when connecting to the gforge db */
define('BUG_TRACK_DB_HOST', 'SERVERNAME or IP ADDRESS');

/** The name of the database that contains the gforge tables */
define('BUG_TRACK_DB_NAME', 'gforge5');

/** The DB type being used by GForge
values: mysql,mssql,postgres
*/
define('BUG_TRACK_DB_TYPE', 'postgres');

/** The DB password to use for connecting to the gforge db */
define('BUG_TRACK_DB_USER', 'USERNAME');
define('BUG_TRACK_DB_PASS', 'PASSWORD');


//define('BUG_TRACK_DB_CHARSET',"windows-1250");
//define('BUG_TRACK_DB_CHARSET',"gb2312");
define('BUG_TRACK_DB_CHARSET',"UTF-8");

/** name of project in the GForge bugtracking system */
/** this value is a placeholder that is replaced by the actual project name for the specified tracker */

define('BUG_TRACK_PROJECT', "qa_main_project");

/** link of the web server url to VIEW an individual bug tracker record */
//define('BUG_TRACK_HREF',"http://gforge.texmemsys.com/gf/project/GFPROJECT/tracker/?action=TrackerItemBrowse&amp;tracker_item_id=");

define('BUG_TRACK_HREF', "http://gforge.MYDOMAIN.com/gf/project/". BUG_TRACK_PROJECT ."/tracker/?action=TrackerItemEdit&amp;tracker_item_id=");

/** link to the bugtracking system, for entering new bugs */
define('BUG_TRACK_ENTER_BUG_HREF', "http://gforge.MYDOMAIN.com/gf");


the main config.inc.php has been updated to reflect the GFORGE bug tracking system selection as well

Code: Select all
$g_interface_bugs = 'GFORGE';


I will take a look inside TL Mantis as well but have had no luck within forum in finding any solutions, so your help is greatly appreciated !!
silvercolt45
Advanced user
 
Posts: 33
Joined: Tue Jan 20, 2009 4:57 pm
Location: Las Vegas

Still need some help.

Postby silvercolt45 » Wed Jan 28, 2009 4:02 pm

I could still use some help in identifying why my install of TL will not connect to the gForge database as expected. I am running Test Link on a linux Ubuntu box temporarily while we evaluate it. Our gForge database is Postgress version 7.4 and all credentials have been verified as functioning with no network connection restrictions.

Within the events log in TL there is the notification that gForge connection could not be established with the number 24. What does this number represent? My gForge configuration file is in accordance to the directions available.

Any help would be greatly appreciated, this is a big selling point for me in getting our team to agree to use this application. I hope to become a continuing advocate and assist more often in these forums as I become acquainted with TL but I need some at the moment.

Thank you! - by the way fman, I have taken a look in Mantis and do not see anything that can be of assistance can you direct me more specifically?
silvercolt45
Advanced user
 
Posts: 33
Joined: Tue Jan 20, 2009 4:57 pm
Location: Las Vegas


Return to TestLink 1.8 (OBSOLETE => EOL)[LOCKED]



Who is online

Users browsing this forum: No registered users and 4 guests