1.8 RC3 install question-ERROR-XML Import/Export cannot work

1.8 related questions and discussions.
Please upgrade to LATEST 1.9.x.
No more fixes for 1.8.

Moderators: Amaradana, TurboPT, TL Developers

1.8 RC3 install question-ERROR-XML Import/Export cannot work

Postby johnzan » Wed Jan 21, 2009 12:30 pm

Hi all,

I'm trying to install TL and I've come up against a very confusing problem.
Using the automated install option I have the following error in the 'Web and PHP configuration' section:

"Checking DOM XML support : ERROR - XML Import/Export cannot work. Please install related library to your web server (You can do it later)."

I have this issue on both a linux XAMPP 1.6.6 and Mac OS X 10.5 machine.

As far as I can tell PHP is setup and configured on both systems correctly.
From the linux machine here is the section of the php.ini:

Output from php -i:

----8<-- Linux php.ini start -----
[root@cactus bin]# ./php -i
phpinfo()
PHP Version => 5.2.5

<lots of unnecessary stuff omitted>

dom

DOM/XML => enabled
DOM/XML API Version => 20031129
libxml Version => 2.6.31
HTML Support => enabled
XPath Support => enabled
XPointer Support => enabled
Schema Support => enabled
RelaxNG Support => enabled

<lots of unnecessary stuff omitted>

xml

XML Support => active
XML Namespace Support => active
libxml2 Version => 2.6.31

xmlreader

XMLReader => enabled

xmlwriter

XMLWriter => enabled

xsl

XSL => enabled
libxslt Version => 1.1.8
libxslt compiled against libxml Version => 2.6.11
EXSLT => enabled
libexslt Version => 1.1.8

----8<-- Linux php.ini end -----

Does anyone have any ideas on where I can check or what I should do to resolve this?

Thanks for any help/advice/suggestions,
John.
johnzan
TestLink user
 
Posts: 8
Joined: Wed Jan 21, 2009 12:14 pm

Postby johnzan » Thu Jan 22, 2009 7:37 am

Hi,

Just following up on this post for the benefit of anyone else that has this issue. The problem is resolved and RC4 will contain the fix. See this link for a workaround in the meantime.

http://www.testlink.org/mantis/bug_view_advanced_page.php?bug_id=2000

Thanks a million to the dev team for such a quick turn around.

Best regards,
John.
johnzan
TestLink user
 
Posts: 8
Joined: Wed Jan 21, 2009 12:14 pm

Postby havlatm » Thu Jan 22, 2009 2:56 pm

It's not RC4 but RC3b.
havlatm
Member of TestLink Community
 
Posts: 940
Joined: Mon Oct 31, 2005 1:24 am
Location: Czech

Postby juanmalimanga » Thu Jan 22, 2009 6:05 pm

I verified the fix and I don't get the Session or DOM XML errors anymore.

[STEPS]

1) Download the configCheck.php file by following the link posted in the previous reply.
2) After unpacking the RC3 files in your web directory, replace the <testlink_dir>/lib/functions/configCheck.php with the one you downloaded.
3) Proceed with installation.


As noted in another thread, the session errors occurred because the browser cache and cookies were not cleared before running the installation.

Hope this helps...
juanmalimanga
TestLink user
 
Posts: 4
Joined: Thu Jan 22, 2009 5:50 pm


Return to TestLink 1.8 (OBSOLETE => EOL)[LOCKED]



Who is online

Users browsing this forum: No registered users and 4 guests

cron