1.7.4 to 1.8 RC1 : Not able to Login

1.8 related questions and discussions.
Please upgrade to LATEST 1.9.x.
No more fixes for 1.8.

Moderators: Amaradana, TurboPT, TL Developers

1.7.4 to 1.8 RC1 : Not able to Login

Postby Subha Moorthi » Thu Jan 22, 2009 6:11 am

I am using testlink 1.7.4 for our project. Then i have upgraded to 1.8.Rc1, Login page is displayed with the following error message

[

ERROR ON exec_query() - database.class.php
1054 - Unknown column 'script_key' in 'field list' - SELECT id,login,password,first,last,email,role_id,locale, login AS fullname, active,default_testproject_id, script_key FROM users WHERE login = 'admin'

THE MESSAGE :: SQL [3] executed [took 0.3423 secs][all took 0.7221 secs]: SELECT id,login,password,first,last,email,role_id,locale, login AS fullname, active,default_testproject_id, script_key FROM users WHERE login = 'admin' Query failed: errorcode[1054] errormsg:Unknown column 'script_key' in 'field list'
ERROR ON exec_query() - database.class.php
1146 - Table 'testlink.events' doesn't exist - DELETE FROM events WHERE fired_at < 1230010681 ORDER BY transaction_id DESC,fired_at DESC

THE MESSAGE :: SQL [6] executed [took 0.0007 secs][all took 2.3773 secs]: DELETE FROM events WHERE fired_at < 1230010681 ORDER BY transaction_id DESC,fired_at DESC Query failed: errorcode[1146] errormsg:Table 'testlink.events' doesn't exist
ERROR ON exec_query() - database.class.php
1146 - Table 'testlink.transactions' doesn't exist - SELECT id FROM transactions t WHERE (SELECT COUNT(*) FROM events e WHERE e.transaction_id = t.id) = 0

THE MESSAGE :: SQL [7] executed [took 0.0507 secs][all took 2.4287 secs]: SELECT id FROM transactions t WHERE (SELECT COUNT(*) FROM events e WHERE e.transaction_id = t.id) = 0 Query failed: errorcode[1146] errormsg:Table 'testlink.transactions' doesn't exist

]


I couldn't login to Testlink, showing message "Wrong user name & password". I have done the following steps for upgrade

1. 1.7.4 testlink folder is deleted from Esay PHP www folder
2. Copied the 1.8 RC1 in to Esay PHP www folder
3. config_db.inc.php & custom_config.inc.php files were modified
4. Restart the PHP service
5. Entered in to Locale web
6. Getting the above Error message

Please help me on this......

Subha
Subha Moorthi
Advanced user
 
Posts: 21
Joined: Sun Sep 14, 2008 6:12 am

Postby havlatm » Thu Jan 22, 2009 2:59 pm

Please, could you use RC3 instead? There is no reason use old build. I hope that it solves your case.
havlatm
Member of TestLink Community
 
Posts: 940
Joined: Mon Oct 31, 2005 1:24 am
Location: Czech

Postby Subha Moorthi » Fri Jan 23, 2009 3:39 pm

RC3 also i am getting the same error
Subha Moorthi
Advanced user
 
Posts: 21
Joined: Sun Sep 14, 2008 6:12 am

Postby havlatm » Mon Jan 26, 2009 10:13 pm

It seems that you miss database migration. Unfortunately it's broken in RC3. Please wait for RC4 and run testlink/install/index.php. Choose migration from 1.7 to 1.8. See installation manual for more information.
havlatm
Member of TestLink Community
 
Posts: 940
Joined: Mon Oct 31, 2005 1:24 am
Location: Czech


Return to TestLink 1.8 (OBSOLETE => EOL)[LOCKED]



Who is online

Users browsing this forum: No registered users and 3 guests