Page 1 of 1

Unable to use TL RC3 after update

PostPosted: Fri Jan 30, 2009 3:08 pm
by ivan karpov
I've updated TL RC2 to RC3. Just rewrited existing files with new ones. But i left the same config, custom_config and config_db.
Then after i login, i'm redirected to link
http://testing/login.php?note=expired
where 'testing' is the machine name, though link to testlink is the following
http://testing/testlink
And system says The requested URL /login.php was not found on this server.
It's clear why - because there is no such file in that folder. But why it's redirected ?
Then i've succeeded to open the main page. After any click i'm still redirected to that link.

Have i done the migration in wrong way ?

PostPosted: Fri Jan 30, 2009 4:16 pm
by johnzan
Hi,

I'm not sure what the cause is but you could try the following:
[1]. clear your browser cache
[2]. remove any old session files on the server.
On my server if I do an 'ls' on '/tmp' I see the following..

[root@cactus results]# ll /tmp/
total 8
srwxr-xr-x 1 root root 0 Jun 5 2008 mapping-root
-rw------- 1 nobody nobody 1392 Jan 30 14:16 sess_1808dd4ba00a4f4c49c98ef5d1b2bed0
-rw------- 1 nobody nobody 1375 Jan 30 08:47 sess_9b40356a57bbc8eb0fbe35085eeb171c
[root@cactus results]#

Other things to look at at the session configuration parameters.

Hope this helps,
J.

PostPosted: Mon Feb 02, 2009 7:08 am
by ivan karpov
unfortunately that didnot help.
I suspect, that it's not a problem of browser.

Can somebody describe the process of upgrade from RC2 to RC3 ?

PostPosted: Tue Feb 03, 2009 1:48 am
by unixadmin007
what if you use ip address instead of hostname, just check and post your result.
I think it is php issue, which version you are using?

PostPosted: Tue Feb 03, 2009 6:59 am
by ivan karpov
no, it didtno help.

php version 5.2.4
I have RC2 installed and RC3.
RC2 works fine with the same DB.

PostPosted: Tue Feb 03, 2009 10:12 am
by testlc
I got the same problem, but managed to solve it using the clear cookie methods.

In Firefox, simply clear all cookies via Tools->Options

In IE, it first fails to me when I simply clear cookie files. but at last it works after I've cleared ALL files via Tools->Internet Options.

Try to clear All and see if it works for you?

PostPosted: Tue Feb 03, 2009 10:23 am
by ivan karpov
NO, it didnot help.
There is a force redirect to the page, that i indicated above.

PostPosted: Wed Feb 04, 2009 11:54 am
by havlatm
There is/was some problem with basehref variable. Please try night build with the latest code. I will look at if it's not already solved here (make an issue in tracker).

PostPosted: Wed Feb 04, 2009 12:32 pm
by ivan karpov
thanks,
i've downloaded the latest version and it's ok now.

PostPosted: Thu Feb 05, 2009 8:35 am
by ivan karpov
I can not download a nightly build,
because i got error on the page:
Incorrect format for file ./languages/ru.txt on line 1.
Format is "variable name[tab]value"