Page 1 of 1

warning after log in to testlink

PostPosted: Wed Dec 15, 2010 11:02 am
by gricolo
Hello everybody!

It is my first post here, but probably not the last.
I'd like some help about a problem which is happen with my testlink.

Has anybody seen this error when log into testlink?

Warning: fopen(/var/www/testlink/logs/userlog7.log) [function.fopen]: failed to open stream: Permission denied in /var/www/testlink/lib/functions/logger.class.php on line 876

It´s appears in the header of testlink after to loggin with JUST some users, not all.

Anyone knows?

Thanks a lot!

Re: warning after log in to testlink

PostPosted: Thu Jan 06, 2011 2:58 pm
by fman
seems a permission problem related to user that runs httpd

Re: warning after log in to testlink

PostPosted: Tue Apr 05, 2011 5:30 pm
by fman
as logs said you have an permission with logs dir and it' files.
user used to run webserver hsa no proper rights.

Re: warning after log in to testlink

PostPosted: Wed Apr 06, 2011 7:44 pm
by mrjingles
Hi!

I have the same problem.
I've tried to change log directory in custom_config.inc.php like this:

Code: Select all
$tlCfg->log_path = '/home/testlink/logs/' ;


but problem still exist. only path in apache error_log was changed:

before:
Code: Select all
[Sun Apr 03 20:18:21 2011] [error] [client 192.168.1.4] PHP Warning:  fopen(/srv/http/testlink/logs/userlog1.log): failed to open stream: Permission denied in /srv/http/testlink/lib/functions/logger.class.php on line 948, referer: http://19
2.168.1.5/testlink/lib/usermanagement/userInfo.php


after:
Code: Select all
[Sun Apr 03 22:06:27 2011] [error] [client 192.168.1.4] PHP Warning:  fopen(/home/testlink/logs/userlog1.log): failed to open stream: Permission denied in /srv/http/testlink/lib/functions/logger.class.php on line 948, referer: http://192.168.1.5/testlink/lib/usermanagement/userInfo.php


On both folders was set 777 permission.
What is wrong?

Thanks in advance.

Re: warning after log in to testlink

PostPosted: Wed Jun 01, 2011 8:23 pm
by jearley3840
I had this issue when I first installed testlink, it was on my login page even before trying to login.

what I did was to go to the /var/www/testlink/logs/ folder and chmod the files inside this folder to allow w (write) as well as read access

chmod -R go+w *.*

Hope this helps