[SOLVED] JIRA connection TL 1.9.6

Ask community to help.

Moderators: Amaradana, TurboPT, TL Developers

[SOLVED] JIRA connection TL 1.9.6

Postby ssperling » Sat Mar 16, 2013 8:36 am

Dear all,

I have a Testlink 1.9.5 installation up and running well. It is connected to our JIRA bugtracker and I am able to create Bugtickets perfectly. I have now installed TL 1.9.6 and connected it to a copy of the old database. When connecting to JIRA I get a strange text e.g. on the Test Excecution (Test Results on Build xyz, execSetResults.php) page. It always says:
Code: Select all
object(SimpleXMLElement)#143 (9) { ["username"]=> string(8) "username" ["password"]=> string(10) "xxxxx" ["uribase"]=> string(42) "https://myprojectmanagement.atlassian.net/" ["uriwsdl"]=> string(74) "https://myprojectmanagement.atlassian.net/rpc/soap/jirasoapservice-v2?wsdl" ["uriview"]=> string(49) "https://myprojectmanagement.atlassian.net/browse/" ["uricreate"]=> string(73) "https://myprojectmanagement.atlassian.net/secure/CreateIssue!default.jspa" ["comment"]=> object(SimpleXMLElement)#144 (0) { } ["projectkey"]=> string(4) "PROJECT" ["issuetype"]=> string(1) "1" }

How can I make this disappear? The main Problem is that the text includes the plaintext password to log TL into JIRA. I could not find any parameter to switch this off.

Thanks for your help
TestLink user
Posts: 1
Joined: Fri Mar 15, 2013 9:56 pm

Re: JIRA connection TL 1.9.6

Postby TurboPT » Sat Mar 16, 2013 2:08 pm

In file: your-testlink-path/lib/issuetrackerintegration/jirasoapInterface.class.php, try to comment-out line 72 so that it looks like this:
Code: Select all
//  var_dump($this->cfg);

Save the file, return to the same area in TestLink, and see if that output is gone.

Let us know, because a Mantis issue may need to be created, but I'm not 100% sure that is the exact line because I don't have JIRA to check.
Member of TestLink Community
Posts: 341
Joined: Sun Dec 10, 2006 4:51 am

Re: JIRA connection TL 1.9.6

Postby fman » Sat Mar 16, 2013 5:44 pm

double work done due to bad use of our guidelines (as usual).
Issue was reported and already fixed.
I will appreciate if users can do a minimun research before posting.
Member of TestLink Community
Posts: 3089
Joined: Tue Nov 15, 2005 7:19 am

Return to Installation and configuration

Who is online

Users browsing this forum: Google [Bot] and 2 guests