[SOLVED] Problem setting up REST API integration (CURL EXT)

Moderators: Amaradana, TurboPT, TL Developers

[SOLVED] Problem setting up REST API integration (CURL EXT)

Postby ogonekorama » Wed Oct 07, 2015 12:31 am

Can you check the configuration file we use for REST API integration with TestLink 1.9.14? I am not sure the config is good that's why I am asking here instead of posting a bug to bug tracker.

As a JIRA REST config we used the one from TestLink distribution package (replaced with our JIRA values):
<issuetracker>
<username>testlink.forum</username>
<password>forum</password>
<uribase>https://testlink.atlassian.net/</uribase>
<uriapi>https://testlink.atlassian.net/rest/api/latest/</uriapi>
<projectkey>ZOFF</projectkey>
<issuetype>1</issuetype>
</issuetracker>

1. Setup JIRA Rest API integration, add it to the test project in TestLink and mark as Active.
2. Go to Test Execution, in a test cases tree click on any test case (in any status: Passed, Failed, Blocked or Not Run) for any test plan

Expected Results:
Test case execution page loads, it should be possible to add bug link for failed test cases

Actual Results:
Test case execution page doesn't load, blank page is displayed. In Network tab of Developer Tools in browser, request
Code: Select all
https://testlinkURL/testlink/lib/execute/execSetResults.php?version_id=357&level=testcase&id=356&form_token=1963918391&setting_build=9

returns 500 Internal Server Error

In TestLink's user log there are no exceptions for this operation:
[5612e67fe742d573384082][DEFAULT][/testlink/lib/execute/execSetResults.php][15/Oct/5 21:07:11][15/Oct/5 21:07:11][took 0.011681 secs]
[>>][5612e67fea365794156188][DEFAULT][/testlink/lib/execute/execSetResults.php][15/Oct/5 21:07:11]
[<<][5612e67fea365794156188][DEFAULT][/testlink/lib/execute/execSetResults.php][15/Oct/5 21:07:11][15/Oct/5 21:07:11][took 0.0092380000000001 secs]
ogonekorama
TestLink user
 
Posts: 7
Joined: Tue Oct 06, 2015 8:21 pm

Re: Problem setting up REST API integration

Postby ogonekorama » Wed Oct 07, 2015 12:37 am

If it helps I can provide access to our TestLink test instance where the problem can be reproduced.
ogonekorama
TestLink user
 
Posts: 7
Joined: Tue Oct 06, 2015 8:21 pm

Re: Problem setting up REST API integration

Postby fman » Wed Oct 07, 2015 5:37 am

1) if you need that I work on your testlink installation this requires that you pay for the service.
2) I'm going to check if I can connect to the testlink JIRA TEST INSTANCE you are trying to connect and if this work this will means that issue is on your side on your installation
may be at OS level.

meanwhile increase (go to internet for right steps) level of log on PHP (need to change php.ini and restart webserver)
Let me know if you want option 1)
fman
Member of TestLink Community
 
Posts: 3063
Joined: Tue Nov 15, 2005 7:19 am

Re: Problem setting up REST API integration

Postby ogonekorama » Wed Oct 07, 2015 4:09 pm

fman, let's try option 2 for now.

For option 1 - what's the price?
ogonekorama
TestLink user
 
Posts: 7
Joined: Tue Oct 06, 2015 8:21 pm

Re: Problem setting up REST API integration

Postby fman » Wed Oct 07, 2015 5:54 pm

Price could be minimum 150 EUR.
You can do other checks like: there is a proxy between your server and internet.
fman
Member of TestLink Community
 
Posts: 3063
Joined: Tue Nov 15, 2005 7:19 am

Re: Problem setting up REST API integration

Postby fman » Wed Oct 07, 2015 6:00 pm

configured with data you have provided
code is latest from github (but is 99% 1.9.14)
issuetracker test OK (from issue tracker management page)
NO PROXY (testing from my house)

Creat issue while executing => OK
created => https://testlink.atlassian.net/browse/ZOFF-1820

then it seems something on your installation
fman
Member of TestLink Community
 
Posts: 3063
Joined: Tue Nov 15, 2005 7:19 am

Re: Problem setting up REST API integration

Postby ogonekorama » Wed Oct 07, 2015 8:48 pm

issuetracker test OK (from issue tracker management page)

Do you mean "Environment" column on Issue Tracker page? It says: OK. Does it mean the issuetracker test is OK?
ogonekorama
TestLink user
 
Posts: 7
Joined: Tue Oct 06, 2015 8:21 pm

Re: Problem setting up REST API integration

Postby ogonekorama » Wed Oct 07, 2015 9:02 pm

Ah, saw the button Check connection!.. - Clicked - it doesn't work the same way as on Test Execution.
Code: Select all
Request URL:https://<url>/testlink/lib/issuetrackers/issueTrackerView.php?id=1
Request Method:GET
Status Code:500 Internal Server Error
ogonekorama
TestLink user
 
Posts: 7
Joined: Tue Oct 06, 2015 8:21 pm

Re: Problem setting up REST API integration

Postby ogonekorama » Mon Oct 19, 2015 3:20 pm

After switching on logging we found out that php5-curl wasn't installed.
After php5-curl package installation JIRA test connection works OK.

Thanks for helping troubleshoot!
ogonekorama
TestLink user
 
Posts: 7
Joined: Tue Oct 06, 2015 8:21 pm


Return to Jira



Who is online

Users browsing this forum: No registered users and 0 guests