Performance for TestLink tree structure

LATEST Official version.
Questions and discussions - NO ISSUES
FOR ISSUES => http://mantis.testlink.org

Moderators: Amaradana, TurboPT, TL Developers

Performance for TestLink tree structure

Postby stef-lhm » Mon Nov 19, 2018 8:24 am

We use TL for several years now. Our actual version ist 1.9.14.
In some of our project (each project more tahn 1000 testcases) the tree structure in testexecution causes many problems, cause it take more than 20 seconds to generate this.
is there any chance to come to 4 or 5 seconds for generating a testexecution page?
I know there is a bug with in the tree strucutre cookie, but maybe there are other things i can do?
stef-lhm
Advanced user
 
Posts: 27
Joined: Thu Jan 31, 2013 7:43 pm

Re: Performance for TestLink tree structure

Postby stef-lhm » Thu Nov 29, 2018 12:24 pm

How to make loading of the tree structure in test exec. faster (1.9.14)? Is there anybody who can help?
stef-lhm
Advanced user
 
Posts: 27
Joined: Thu Jan 31, 2013 7:43 pm

Re: Performance for TestLink tree structure

Postby stef-lhm » Mon Feb 18, 2019 10:32 am

We did the update to TestLink 1.9.19 and we still have the problem, that the loading of the treestructur in testexecution needs to much time.
Anybody else, who have a problem like this?
Are there any hints how to fix this problem?
stef-lhm
Advanced user
 
Posts: 27
Joined: Thu Jan 31, 2013 7:43 pm

Re: Performance for TestLink tree structure

Postby stef-lhm » Mon Feb 18, 2019 10:45 am

It takes 30 to 40 seconds to build up the treestructure
stef-lhm
Advanced user
 
Posts: 27
Joined: Thu Jan 31, 2013 7:43 pm

Re: Performance for TestLink tree structure

Postby stef-lhm » Mon Feb 18, 2019 1:59 pm

This effect happens in small projects with less testcases, too.
I think that most of this delay time happens in the browser. But even in new browsers this problem exists. Maybe the problem with the large cookie?
stef-lhm
Advanced user
 
Posts: 27
Joined: Thu Jan 31, 2013 7:43 pm

Re: Performance for TestLink tree structure

Postby stef-lhm » Thu Feb 21, 2019 9:55 am

After searching on what happens on the database, we know a bit more about the performance problem.
Testlink opens a session on DB. After that, nothing happens. This session is in sleep state for more than 10 seconds. Then the 3 queries come in. it takes 1-2 seconds to do the queries.
So it takes 20-40 seconds from klicking "testexecution" in TestLink until we can see the complete treestructure. The question is, why is the session for such a long time in sleep state? Is anybody out there who knows about that problem and knows how to fix it?
Thanx
stef-lhm
Advanced user
 
Posts: 27
Joined: Thu Jan 31, 2013 7:43 pm

Re: Performance for TestLink tree structure

Postby stef-lhm » Thu Feb 21, 2019 10:06 am

just to add two other facts,
- we use MySQL 5.7.24
- the session will be closed immediately after finishing the quieries

so the problem is open the session - !!!SLEEP!!! - query/close session
stef-lhm
Advanced user
 
Posts: 27
Joined: Thu Jan 31, 2013 7:43 pm

Re: Performance for TestLink tree structure

Postby stef-lhm » Fri Feb 22, 2019 7:47 am

In my userlog, i found out, that execDashboard.php and execNavigator.php took 15 to 17 seconds each.
stef-lhm
Advanced user
 
Posts: 27
Joined: Thu Jan 31, 2013 7:43 pm

Re: Performance for TestLink tree structure

Postby stef-lhm » Fri Feb 22, 2019 12:34 pm

ok i found the solution.

$tlCfg->tree_filter_cfg->testcases->execution_mode->filter_assigned_user = DISABLED;

If i enable this, it takes much to long to build the drop down with all users. this causes 20 to 40 seconds delay in response time.
stef-lhm
Advanced user
 
Posts: 27
Joined: Thu Jan 31, 2013 7:43 pm


Return to TestLink 1.9



Who is online

Users browsing this forum: No registered users and 6 guests