New install 1.9.19 w/ issues

Ask community to help.

Moderators: Amaradana, TurboPT, TL Developers

Post Reply
mkelly19
TestLink user
Posts: 5
Joined: Mon Dec 23, 2019 3:32 pm

New install 1.9.19 w/ issues

Post by mkelly19 »

Hello,
I have a new installation of 1.9.19 running xampp on win2016. I am currently trying to solve why the user page doesn't load, I tried some things but seem like a whack mole situation, and hoping there is an easier solution.

Here are the things that I have done:

I used these instructions for install:
https://www.tutorialspoint.com/testlink ... lation.htm

After first login encountered:
These changes occur in the config.inc.php

Warning: Creating default object from empty value in C:\xampp\htdocs\Testlink\config.inc.php on line 844
Resolved with: ini_set('error_reporting', E_ALL);

Attempted some imports:
I also needed to add to declare $tlCfg->resultMatrixReport as part of the standard class:

$tlCfg->resultMatrixReport=new stdClass();

For importing need to modify the defaults
c://xampp/php.ini
max_execution_time=300 default was 120

config.inc.php:

$tlCfg->import_file_max_size_bytes = '40960000';
$tlCfg->import_max_row = '100000'; // in chars
$tlCfg->repository_max_filesize = 10; //MB

smaller files work fine larger files have some xml issues.. I can work through those.

When I attempt to load the user page I get:
Fatal error: Uncaught Error: Object of class tlExtTable could not be converted to string in C:\xampp\htdocs\Testlink\gui\templates_c\1130345fece6a6ce888c8cb00a99e832df288f7b_0.file.usersView.tpl.php:51 Stack trace: #0 C:\xampp\htdocs\Testlink\vendor\smarty\smarty\libs\sysplugins\smarty_template_resource_base.php(123): content_5e0f912f2f1ee3_56653548(Object(Smarty_Internal_Template)) #1 C:\xampp\htdocs\Testlink\vendor\smarty\smarty\libs\sysplugins\smarty_template_compiled.php(114): Smarty_Template_Resource_Base->getRenderedTemplateCode(Object(Smarty_Internal_Template)) #2 C:\xampp\htdocs\Testlink\vendor\smarty\smarty\libs\sysplugins\smarty_internal_template.php(216): Smarty_Template_Compiled->render(Object(Smarty_Internal_Template)) #3 C:\xampp\htdocs\Testlink\vendor\smarty\smarty\libs\sysplugins\smarty_internal_templatebase.php(232): Smarty_Internal_Template->render(false, 1) #4 C:\xampp\htdocs\Testlink\vendor\smarty\smarty\libs\sysplugins\smarty_internal_templatebase.php(134): Smarty_Internal_TemplateBase->_execute(Objec in C:\xampp\htdocs\Testlink\gui\templates_c\1130345fece6a6ce888c8cb00a99e832df288f7b_0.file.usersView.tpl.php on line 51

I tried to instantiate $_smarty_tpl=new stdClass(); in teh userassigned and userview.tpl.phps
mkelly19
TestLink user
Posts: 5
Joined: Mon Dec 23, 2019 3:32 pm

Re: New install 1.9.19 w/ issues

Post by mkelly19 »

Here is the code for line 48-51 from the usersView.tpl.php. When I instantiated $_smarty_tpl in userviews the next error was in userassigned. I could not find tlExtTable in any of the files line on this fatal error.

foreach ($_from as $_smarty_tpl->tpl_vars['idx']->value => $_smarty_tpl->tpl_vars['matrix']->value) {
$_smarty_tpl->tpl_vars['__smarty_foreach_initializer']->value['index']++;
$_smarty_tpl->tpl_vars['__smarty_foreach_initializer']->value['first'] = !$_smarty_tpl->tpl_vars['__smarty_foreach_initializer']->value['index'];
?>
mkelly19
TestLink user
Posts: 5
Joined: Mon Dec 23, 2019 3:32 pm

Re: New install 1.9.19 w/ issues

Post by mkelly19 »

I was never able to resolve this installation of 1.9.19-20 I got from scourgeforge.net

I had no issues with the installation provided by https://bitnami.com/stack/testlink
fman
Member of TestLink Community
Posts: 3122
Joined: Tue Nov 15, 2005 7:19 am

Re: New install 1.9.19 w/ issues

Post by fman »

Good to know that you have solved your issue
Sri12300
TestLink user
Posts: 1
Joined: Mon Apr 25, 2022 11:13 am

Re: New install 1.9.19 w/ issues

Post by Sri12300 »

I am getting the same error and I am not a developer to debug and fix it. Can someone please help me fixing this issue?

Fatal error: Uncaught Error: Object of class tlExtTable could not be converted to string in D:\xampp\htdocs\testlink-1.9.19\gui\templates_c\0e9e91f37f8845594d98d248aadde90b0dbf36b9_0.file.usersView.tpl.php:52 Stack trace: #0 D:\xampp\htdocs\testlink-1.9.19\vendor\smarty\smarty\libs\sysplugins\smarty_template_resource_base.php(123): content_62948186ac3aa3_00712802(Object(Smarty_Internal_Template)) #1 D:\xampp\htdocs\testlink-1.9.19\vendor\smarty\smarty\libs\sysplugins\smarty_template_compiled.php(114): Smarty_Template_Resource_Base->getRenderedTemplateCode(Object(Smarty_Internal_Template)) #2 D:\xampp\htdocs\testlink-1.9.19\vendor\smarty\smarty\libs\sysplugins\smarty_internal_template.php(216): Smarty_Template_Compiled->render(Object(Smarty_Internal_Template)) #3 D:\xampp\htdocs\testlink-1.9.19\vendor\smarty\smarty\libs\sysplugins\smarty_internal_templatebase.php(232): Smarty_Internal_Template->render(false, 1) #4 D:\xampp\htdocs\testlink-1.9.19\vendor\smarty\smarty\libs\sysplugins\smarty_internal_templatebase.php(134): Sm in D:\xampp\htdocs\testlink-1.9.19\gui\templates_c\0e9e91f37f8845594d98d248aadde90b0dbf36b9_0.file.usersView.tpl.php on line 52
fman
Member of TestLink Community
Posts: 3122
Joined: Tue Nov 15, 2005 7:19 am

Re: New install 1.9.19 w/ issues

Post by fman »

get code from github branch testlink_1_9_20_fixed
Post Reply