Post Reply
Member of TestLink Community
Posts: 3123
Joined: Tue Nov 15, 2005 7:19 am


Post by fman »

Before requesting details - POOR
I need pointers to improve the regression plan

1) I have this TC-1 and under Test Execution system correctly showed it to TestPlan01 and Build01
2) However requirements changed I updated the TC-1 from Test Specification tab and again trie adding to to Test Plan01 but the checkbox is read only and hints that it is already added
3) Test Execution tab however still shows the version01 of the testcase
4) I tried saving it to Not Run, reloading, sign out but all in vain

AFTER REQUESTING details => VERY GOOD explanation
1) Login to test link
2) Click Test Specifications
3) Click create new version button for a test case say TC-31 which is already added to test plan TP-1
4) Update few details of TC-31 and save it
5) System correctly creates version2 for TC-31
6) I then click add to test plan button to add this new version to TP-1
7) System opens a dialogue and shows checkox of TP-1 selected and read only
8) Expectation - System should have shown me the checkbox as this new TC-31 is not part of testplan TP-1
9) When I go to Test Execution tab and see TC-31
10) I see that the version1 is being displayed
11) Expectation - system should have shown the latest version as NOT RUN instead of showing the old version of the test case

- I was temporarily able to solve my problem by obeying following 2 steps:
(a) On dashboard there was a section "Update Linked Test Case Versions"
(b) Here I could see a drop down to link version02 of TC-31 to TP-1 which solved it.
Post Reply